Gnome-Shell building fails on Arch Linux

Hi everybody,

I'm using Arch Linux and I would like to build a bleeding edge snapshot of gnome-shell, however jhbuild fail at step 3 with the following error:

./json-parser.c:916:38: error: comparison between ‘GTokenType’ and ‘enum <anonymous>’

If I continue the build process it ends saying success, however when I launch ./gnome-shell --replace I get something like GConf schemas missing, killing the shell.

Besides, I tried to compile on Fedora and it works like a charm, am I missing some dependency which I am not aware of?

I tried the Arch AUR package and it works fine (now I have the GConf schemas thanks to it, so I can't reproduce the previous error), however I would like to be able to compile the lastest source.

I searched through Google but I can't find anything related to my problem, is anybody able to help me?

Thanks in advance, and keep up with the project!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]