Re: [gpm] Video not restored after s3 suspend on Intel Extreme graphics 2 card

Hash: RIPEMD160

Richard Hughes wrote:
> On Wed, 2006-03-22 at 10:17 +0000, John Hunt wrote:
>> I'm using GPM 2.13.93.
>> I'm using an IBM Thinkpad R50e which has an Intel Extreme Graphics 2
>> video card built in. When I try to suspend the laptop with GPM or via
>> the suspend option on the main gnome menu the system goes into suspend
>> mode properly, and comes out properly also but my video state is not
>> restored (i.e - I'm left with a blank screen).
>> I have had suspend working properly before by using acpid and a little
>> script
>> (
>> to dump and restore the graphics cards state, however I get the
>> feeling
>> GPM bypasses any acpid stuff as it's HAL based (I checked the
>> /var/log/acpid, and GPM left nothing in there).
> Yes, acpid is not required any more, and any scripts tend to upset g-p-m
> and hal.
>> I have tried the various kernel parameters such as acpi_sleep=s3_bios,
>> but they tend to make things worse (unable to come out of suspend
>> mode).
>> I'm thinking possible solutions could be to install the latest CVS of
>> GPM, or finding a way to get GPM to fire off a script upon suspend.
>> However, I'm no guru of GPM or HAL/DBUS etc.. so I ask for your help!
> You might want to look
> at /usr/share/hal/scripts/hal-system-power-suspend which has the suspend
> magic -- I'm sure you can add any needed stuff in there as it's run as
> root.
> The logic is as follows: g-p-m calls Suspend() on HAL. HAL calls the
> hal-system-power-suspend script which does different stuff depending on
> what tools you have installed or what distro you are running.
> Please tell me if that doesn't fix the problem, or you need any more
> help.

Thanks Richard, this was the solution I was looking for, however, I
couldn't get it to work. Using my little cat /proc/bus/pci/(gfx card) >
/tmp/videostate almost worked, however, things were quite scrambled on
restoring it.

Not sure where to go from here. I tried several combinations of using
the script with echo mem > /sys/power/state (which seemed to work better
than /usr/sbin/pm-suspend.

I get the feeling it's something to do with cairo or some kind of funny
xorg module.

Let me know if you have any ideas! Perhaps a preventative measure would
be better...

Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Fedora -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]