[gpm] Suspend/Resume has not worked since kernel-2.6.16

I've been in a FC5  holding pattern because none of the kernels after
2.6.16-2133 will wake up after a suspend to RAM.  I've got the
kernel's agpgart turned off and have tried suspending with and without
the NVidia AGP driver running.  Results are same.

This system is a Dell Latitude D820 with Nvidia Quadro video card.
I've tried both of the X drivers, the "nvidia" and the "nv" versions,
and results are the same.  Sometimes I can log into the system from
outside and reboot to bring back the video.  That proves that the
ipw3945 driver does wake up from suspend, anyway.  On those occasions,
I can see disk activity.  Other times, the system seems completely
dead, not flicker of disk LED, no network response.

When I asked about suspend problems and 2.6.17 in this list a couple
of weeks ago, Richard said he had the same trouble with
suspend/resume.  However, I don't see a hell of a lot of hollering
about this in the Internet, which either means that people have not
yet installed the newer kernels or that they don't suspend much. Or
else my machine is the only one that doesn't work :(.

In the Fedora bugzilla, there are some people who report that the xorg.conf
 Option "VBERestore" "True"
corrects the problem.  Tonight I worked on a Toshiba Satellite M55
that uses the i810 X driver and with kernel 2.16.17, that option was
necessary to wake up the video after suspend.  However, that option
does not help with "nv" or "nvidia" drivers, both report in the X log
that the option is not used.  Documentation in "man nv" seems to
support that interpretation.

So I'm stuck running kernel 2.6.16-1.2133_FC5smp.  And I'm happy to do
that, except that I can't find RPMS for kernel-devel on Fedora servers
or RPMS for drivers on the ATrpms site.  So if I want to reinstall the
nvidia RPM, I'm stuck.  That kinda sucks.  I think the servers should
keep packages for the last version of 2.6.16.

When the system locks, there is no information in the messages and
there's no Error report in X.log.

Here are some versions I'm running.


What do you think?

Paul E. Johnson
Professor, Political Science
1541 Lilac Lane, Room 504
University of Kansas

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]