Re: z22 F7 problem

----- Original Message -----
From: Tom Billiet
Time: 29-09-07 11:20
> ----- Original Message -----
> From: Reitsma, Rene - COB
> Time: 29-09-07 02:03
>> Dear All,
>> I am not sure if this is the right forum to request help. If it's not,
>> please accept my apologies and ignore this message. If it is, perhaps
>> one of you can help me as I'm at the end of my rope.
>> After successfully syncing my palm Z22 with Evolution calendar with
>> gpilot for more than a year in Fedora Core 6, I am no longer able to
>> sync with F7. From the moment I 'upgraded' to F7, the sync stopped
>> working.
> Same for me here, it was not FC7, but is was also "some" upgrade that
> made it stop working, I suspect a kernel upgrade where the usb timing
> has changed...
> [snap]

okay, I've been looking somewhat further and made some progress.

I've hacked the pilot-link usb.c file, and now I can use "pilot-xfer -l
-p usb:", I've never been able to use this before, and it works now
every time, so that's definitively a progress, hooray :-)
I'll attach my patch. Please notice that this is a very ugly hack and
will break support for other devices in pilot-link, but it's just a
test. Other z22 users, please try and report...

Now so far for the good news, gpilotd is still not working. It's now
already doing something (spitting out the same "USING NET" messages as
using visor), but still no sync...

--- libpisock/usb.c	2007-02-09 15:26:09.000000000 +0100
+++ libpisock/usb-z22.c	2007-10-02 22:17:23.000000000 +0200
@@ -960,17 +960,17 @@
 	/* query bytes available. Not that we really care,
 	   but most devices expect to receive this before
 	   they agree on talking to us. */
-	if (!(flags & USB_INIT_TAPWAVE)) {
+	/*if (!(flags & USB_INIT_TAPWAVE)) {
 		unsigned char ba[2] = { 0 };
 		ret = dev->impl.control_request (dev, 0xc2, GENERIC_REQUEST_BYTES_AVAILABLE, 0, 0, &ba[0], 2, 0);
 		if (ret < 0) {
-			LOG((PI_DBG_DEV, PI_DBG_LVL_ERR, "usb: GENERIC_REQUEST_BYTES_AVAILABLE failed (err=%08x)\n", ret));
+			LOG((PI_DBG_DEV, PI_DBG_LVL_ERR, "usb: GENERIC_REQUEST_BYTES_AVAILABLE failed (err=%08x)\n", ret));*/
 			/* configuration have to fail to skip this device - or LifeDrive(?) devices will hang */
-			return -1;
+			/*return -1;
 		LOG((PI_DBG_DEV, PI_DBG_LVL_DEBUG, "GENERIC_REQUEST_BYTES_AVAILABLE returns 0x%02x%02x\n", ba[0], ba[1]));
-	}
+	}*/
 	return 0;

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]