Problem installing files onto multiple devices


I am able to successfully install files using gnome-pilot utility to only one of my two Treo650 devices, but not to the second device that I had configured.  I'm using the same USB cradle for both, connected to the same USB port on the back of the computer (there are several ports on this motherboard).  I'm running on a x86_64 Fedora 7 machine, with all updates applied.  I'm using gnome-pilot applet version 2.0.15.    I am able to use the Backup conduit to backup from both devices into their respective different directories, so the Backup conduit is working for both devices.  I am able to drag and drop a .prc file from a Nautilus window onto the gnome-pilot panel applet icon, connect the USB connector to the first first Treo650, click the hotsync button, and see the .prc file being installed properly.  Repeating those steps using the second Treo650 results in only the backup conduit activating and working, but not the File conduit.

Seeing a previous thread at gnome org/msg00788.html that states:

You can also use the gpilot-install-file utility from the command line,
which works either interactively or schedules the file for upload at
your next sync (using the '--later' option).

I tried that on the second Treo650 and saw this output when connecting the second Treo650:

bash-3.2$ gpilot-install-file --now ~/Treo650SyncData/CardExport2.prc
gpilotd-Message: Activating object OAFIID:GNOME_Pilot_Daemon

where "<blink>" is the cursor blinking waiting for something to happen.  I pressed the hotsync button, and the second Treo650 synced, but the cursor stayed right where it was.  After the sync of the second Treo650 finished, I reconnected the first Treo650, and pressed the hotsync button on the cable, and wallah, I saw the file being transferred on the gpilot-install-file output which now reads:

bash-3.2$ gpilot-install-file --now ~/Treo650SyncData/CardExport2.prc
gpilotd-Message: Activating object OAFIID:GNOME_Pilot_Daemon
fileconduit-Message: BrentsTreo650 completed 1169078866
bash-3.2$ <blink>

gpilot-install-file version is 1.0 (as reported from --version command line option).

There are two different PDAs listed in the PDAs panel of the gnome-pilot Settings, each with a different Name, ID, and Owner, and I verified that the Local Directory attribute on both PDA's is unique and writeable by the user.  Note that the same UNIX user is being used here for both, but that should not matter hopefully.

Anyone have any ideas as to why the File conduit would be hardcoded to transfer to the first Treo650 device?  I have not yet tried using two different USB ports with two different USB cables, but that should not matter should it?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]