Re: [Resend] Compiling gnome-media 2.10.2

On 5/6/05, Ronald S. Bultje <rbultje ronald bitfreak net> wrote:
> We have the ./ script which will do everything in the right
> order. I assumed you were familiar with building software from CVS.
> After automake, you commonly run autoconf and ./configure. For the
> warnings you're getting, you'll need to install gettext-devel,
> gconf-devel and some more -devel packages.
> If you don't know how to do that, I'd suggest waiting for the next
> tarball in the 2.11 series, which will include this fix.

Ok so I decided I cant wait ....... got the rest of Gnome 2.10.1
working (bar a slight problem in evolution) and it is just goading me
that I cant change the volume control use sound-juicer etc ......

Did some googling and it suggested with the errors I was getting I run
the commands in the following order

./configure --prefix=/opt/gnome2.10.1

Tried aclocal with ACLOCAL_FLAGS="-I /opt/gnome2.10.1/share/aclocal -I
/usr/local/share/aclocal -I /usr/share/aclocal" and I get errors, warning: macro `AM_GCONF_SOURCE_2' not found
in library warning: macro `AM_GLIB_GNU_GETTEXT' not
found in library

I know for a fact that these two macros are defined in *.m4 files in
/opt/gnome2.10.1/share/aclocal which is included via ACLOCAL_FLAGS

[root jersey:/sources/gnome-media-2.10.2]# grep AM_GCONF_SOURCE_2
/opt/gnome2.10.1/share/aclocal/gconf-2.m4:dnl AM_GCONF_SOURCE_2

[root jersey:/sources/gnome-media-2.10.2]# grep AM_GLIB_GNU_GETTEXT
/opt/gnome2.10.1/share/aclocal/glib-gettext.m4:# using AM_GLIB_GNU_GETTEXT
/opt/gnome2.10.1/share/aclocal/glib-gettext.m4:# AM_GLIB_GNU_GETTEXT

So I am stumped.

Next drastic thing to try CVS HEAD (gnome-media only) here I come ........


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]