0.8 in 2.6 ?

Hi people,
I'm out for opinions again.
There's 2 questions I really want to get nailed down, because I want to steer 
our development and Rhythmbox into the right direction.

1) Do we want GStreamer 0.8 released in time for Gnome 2.6?
This means: Can we add all the features to the core that are needed for 
everything we want supported with that release? We do not need to get all the 
plugins feature-complete as they can be extended later on. Another thing is 
obviously: Do apps using GStreamer need 0.8 or are they all happily using 0.6?

2) What features do we need that need API/ABI changes and that should go into 

I'd like to get that sorted out now so I know if there are deadlines we 
need/want to meet. Some people said we want that while others weren't sure we'd 
be able to meet that deadline.
And I definitely don't want to look bad again in front of the release team when 
we slip schedules again.

As for my personal opinion: 
I want 0.8 in 2.6. I hate it that loads of our developers power is lost on some 
dead-end branch where it could put to use to do important stuff on the branch 
that has a future.
The features that come to mind immediately are
- interactivity
- tags
- gettext support
- interfaces

Features that could be implemented without breaking API/ABI later on - during a 
stable 0.8 branch:
- more interfaces/implementing interfaces in the plugins
- a new autoplugger
- more plugins
- an extensive testsuite

So much for me,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]