Re: [gnome-love] jhbuild gudev: invalid hash attribute on module

It worked!!!


On Wed, May 2, 2012 at 8:12 AM, Craig Keogh <cskeogh adam com au> wrote:
On Wed, 2012-05-02 at 04:09 -0400, Anna Zacchi wrote:
> The real problem is that I cannot jhbuild udev because of problems
> with versions:
> =========
> libtool: Version mismatch error.  This is libtool 2.4, but the
> libtool: definition of this LT_INIT comes from libtool 2.2.6.
> libtool: You should recreate aclocal.m4 with macros from libtool 2.4
> libtool: and run autoconf again.
> make[2]: ***
> [extras/gudev/extras_gudev_libgudev_1_0_la-gudevmarshal.lo] Error 63
> ==========
> the suggestion is to " recreate aclocal.m4 with macros from libtool
> 2.4". How can I do that?
> Or do you suggest to do something else?

From the information you've provided, I think you've previously done a
'jhbuild bootstrap'. I don't recommend 'jhbuild bootstrap'. I've
recently updated the documentation to include this recommendation - the
on-line documentation will update soon.

To fix the problem, you could either:
1. delete your prefix (normally /opt/gnome) and run a full build again;
2. 'jhbuild -m bootstrap uninstall libtool' and rebuild gudev.

Craig Keogh <cskeogh adam com au>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]