Re: gdm permissions problem


I suffer with somewhat the same problem i installed a lot gdm themes
in GNOME and then kept changing those themes according to my choice,
Then one fine day i changed the theme and logged of and logged on when
the Linex came to load that theme it tried certain times and then
reported an error that GDM failed to load, and then runs in linux
prompt mode

Tech. Spec. OS - mandrake linux 9.0,
Compaq - presario laptop. 

On Fri, 18 Feb 2005 10:58:28 -0500, David A. Cobb <Superbiskit cox net> wrote:
> I made some changes in the '/etc/profile' and my own '.profile', now if
> I use gdm as my 'default-display-manager', I get the following symptoms:
> The X-server starts, and paints the grey background.  The background
> color for the greeter is painted, as is the white background of what
> will be the 'Username' input is painted.  NO detail foreground, no
> words, etc.
> If I move the mouse, the cursor follows, and changes shape over the
> 'Username' area.
> After a very long wait (3 - 5 minutes), the system 'beeps' and paints
> the foreground.  Now, if I move the mouse pointer over the input area,
> it vanishes rather than changing to an I-bar.  Keystrokes are not echoed
> and menus don't drop down when clicked.  Initially, I believed the
> program was simply not setting up for input.
> If I ignore the lack of feedback and type my username, then go away and
> brew a pot of coffee ( another 5 - 10 minutes ), my username echos and I
> get a password prompt.  If my actions included clicking on, say,
> 'Session,' the menu drops after the same delay.  Curiously, the menu is
> immediately responsive when it does drop.
> If I type my password, then go off to drink the coffee, I come back to
> find the "Your session lasted less than 10-seconds ..." display.
> Like the menus when they finally drop, this panel is immediately
> responsive to display the error condition (below).  However, the display
> of the .xsession-errors includes a scroll-bar that is not responsive
> except with a long delay.
> ISTR, long ago I worked on a *Nix machine with X and it was vital that
> the startup scripts not do any output.  I don't know whether this is
> still true.
> The .xsession-error output is:
> /etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
> /etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w
> /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l
> ":0" "superbiskit"
> /etc/gdm/Xsession: Beginning session setup...
> mkdtemp: private socket dir: Permission denied
> Xsession: X session started for superbiskit at Thu Feb 17 21:36:26 EST 2005
> open: Permission denied
> ***
> If I try using XDM as my display manager, in addition to the lost
> functionality of GDM, I get the following deviant behavior:
> I can log in as 'root.'  That's how I'm able to send this.
> If I offer any other username, I get an X-Server restart.
> I have purged and re-installed gdm, twice now.  It didn't help.
> Please provide a clue, as I'm suddenly clue-less.
> Thanks in advance
> _______________________________________________
> gnome-list mailing list
> gnome-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]