Solved Re: Blank Screen, Gnome Config Problem?

Thanks everyone for all the suggestions. I am still not sure what the root cause of my desktop configuration problem was, but it is now back to normal. A very early suggestion was that I had multiple instances of X initiated, and there is a possibility that this may have been part of the problem. Thanks to Sean for his suggestion to log into a virtual consol. I logged in as my normal user, then su'd to root and started X using the command Sean provided below, when the X and Gnome session came up for the root user it was back to normal. I saved the setting, logged out, then back in, and everything looks fine. I am not sure what the cause/solution was but it is ok now. If anyone has a good understanding of what happened please fill me in. My big lesson, ...only log into root when it is absolutely necessary.


----- Original Message ----- From: "Sean Middleditch" <elanthis awesomeplay com>
To: "Jeff Boyce" <jboyce meridianenv com>
Cc: "Ryan McDougall" <NQG24419 nifty com>; <gnome-list gnome org>
Sent: Friday, April 08, 2005 1:38 PM
Subject: Re: Blank Screen, Gnome Config Problem?

First off, and I haven't read all the responses to the thread, is the
problem just that your Nautilus package got removed?

Second, if it is installed, simply starting Nautilus should guarantee
that it'll start on your next login, instead of blasting away all your
useful settings.  Does that help?

Third, for diagnosis as you mentioned you would like to see, log into a
virtual console (ctrl-alt-F<N> to get to one) and start up your desktop
using the command:
 startx -- :1 > xsession.log 2>&1
Once you exit the X session, you can type:
 less xsession.log
to view any errors printed to the console during the X session.

Finally, if you still have problems, blasting your settings away should
fix the problem.  Make sure you are not logged into the desktop when you
do it, though, and that all desktop processes (like gconfd) are shutdown
before deleting the preferences in ~/.gconf and ~/.gnome2 and so on.  A
clean way to do that is to reboot, log in on a virtual console, and
delete the preferences folders and files there.

On Fri, 2005-04-08 at 13:23 -0700, Jeff Boyce wrote:
I have tried the approach of renaming the .gconf and .gnome directories so that they would get recreated upon starting X the next time. The result was the same blank desktop. Another similar approach that was suggested was to
create a new dummy user and copy the configuration files from that user.
This caused more problems due to the references back to the dummy user,
although I was able to rectify that. So I am back to my original problem,
which essentially boils down to how do I restore my gnome desktop to its
original status? I didn't have any customized workspace so I am not worried
about losing anything like that.  Any more suggestions folks?

----- Original Message ----- From: "Ryan McDougall" <NQG24419 nifty com>
To: "Jeff Boyce" <jboyce meridianenv com>
Cc: <gnome-list gnome org>
Sent: Friday, April 08, 2005 4:26 AM
Subject: Re: Blank Screen, Gnome Config Problem?

> This isn't great advice, but you could try blasting any .dotfile
> or .directory, especially .xinitrc. Make sure you back up any data
> first, but there really shouldn't be any. Actually you probably
> shouldn't even be using root in X, there's no need.
> Cheers,
> Ryan
> On Thu, 2005-07-04 at 14:10 -0700, Jeff Boyce wrote:
>> I am a relatively new, novice Linux user looking for assistance with a
>> problem that I am sure I created as a result of my inexperience.  I am
>> pretty good at diagnosing problems, but am not familiar with Linux >> enough
>> to
>> know where to look.
>> System:  Dell PE2600, RHEL3, configured as file server with Samba
>> Problem: A blank (i.e., black) desktop without any icons when >> starting X >> manually as root user. Can not open a file manager window. Also a >> long
>> delay occurs (1-2 minutes) when logging out of X.
>> Events Leading Up to Problem: The only unique actions that occurred >> on
>> the
>> system the previous day included the
>> installation of the NUT (network ups tools) software from source, and >> the
>> subsequent uninstallation of NUT.  I had never installed from source
>> before
>> and the installation went fine without errors.  There was not a *make
>> uninstall* for the program so I followed some instructions to review >> the
>> *makefile* to see where all the files where installed and delete the
>> files/directories manually.  The following directories were removed
>> (actually moved to Trash).  The install and uninstall both occurred as
>> the
>> root user.
>> /opt/NUT/nut-2.0.1    (contained the unzipped source files)
>> /usr/local/ups/man
>> /usr/local/ups/share
>> /usr/local/ups/bin
>> /usr/local/ups/sbin
>> Diagnostic tests/actions tried:  These problems do not occur when
>> starting X
>> from a non-root user.  As suggested by someone I have checked the
>> permissions on the /root/.gconf directory (700) and they are the same >> as
>> the
>> permissions on a normal users directory /home/jeffb/.gconf directory
>> (700)
>> that has a normal desktop.  I am unable to see if there are any error
>> messages sent to screen when X starts (a recommendation on how to >> capture >> this information would be appreciated), but when X finally shuts down >> the
>> list below includes some of the information on the screen.  The AUDIT
>> statement is also listed in the /var/log/Xfree86.0.log file.
>> Session_Manager=local/bison:/tmp/.ICE-unix/2422
>> AUDIT: Thu Apr  7 09:00:58 2005: 2418 X: client 4 rejected from local
>> host
>> Option given which is no longer supported in this version of
>> Gnome-terminal;
>> you might want to create a profile with the desired setting, and use >> the
>> new --window-with-profile option
>> Unable to open desktop file applications:
>> ///Office/redhat-word-processor.desktop for panel launcher: Error >> reading
>> file 'applications:///office/redhat-word-processor.desktop' : file not
>> found
>>    <snip>
>> Saving Session:
>> gnome-terminal --use-factory --window-with-profile-internal-ID=Default >> --show-member
>>  --role=gnome-terminal-14721 --1476088167-1090439518  --title
>> root bison:~ --working-directory /root --zoom 1
>> Waiting for X server to shut down
>> I would appreciate any suggestions on what to look for, where to look,
>> other
>> diagnostic steps, etc. that will assist me in returning my root user
>> desktop
>> back to normal.  Could a solution be a simple as copying a set of
>> configuration files from a user that is working normally?  If so what
>> files?
>> Thanks for any assistance.
>> Jeff Boyce
>> _______________________________________________
>> gnome-list mailing list
>> gnome-list gnome org

gnome-list mailing list
gnome-list gnome org

Sean Middleditch <elanthis awesomeplay com>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]