Solved: Re: Problems with bonobo activation server

On Wed, Aug 18, 2004 at 12:53:05PM +0100 or thereabouts, Nuno Donato wrote:
> Hello
> My hard disk had some problems yesterday and everything just stop
> working. After a reboot and about 10 fscks i managed to boot with no
> problems again. Everything worked again except gnome-panel. After the
> login is complete, nautilus is working, metacity is working too but
> the panel displays the following error message:
> There was a problem registering the panel with the bonobo-activation server.
> The error code is: 1
> The panel will now exit.
> I've tried reinstalling libbonobo with no sucess. I've also tried with
> a fresh new user(without any prefs) but the problem persists. Any hint
> on how can i solve this?

For the archives: this was solved on IRC. 

It wasn't some stale socket or lockfile or something in /tmp, 
(always worth a look when you're stuck :)) because /tmp had 
been emptied before rebooting. 

Nuno had been using a package-management system: rpm. So ran
rpm -V on a variety of gnome rpm packages. rpm -V is rpm --verify:
it compares what the rpmdb thinks should be there with what 
is actually there. 

rpm -V only complains if there's a problem. So getting your
prompt back with no errors is a good thing. Eventually, Nuno
got lots of "missing file" results on rpm -V gnome-panel.

Reinstalled gnome-panel rpm and all was well again.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]