Re: How to install rpms with Gnorpm?

On Mon, Jul 01, 2002 at 06:06:16AM +0200, Mail Liste wrote:
> Have big trouble installing rpms with Gnorpm in a RH 7.3 environment.

Oh dear, this is probably my fault. What can I say ... I'm a slack bozo.

> First minor problem is that the search function in Gnorpm dont work. Not
> on computer, and not on the web. I get no answers even if I know a
> program is on my computer. Tried xbill to be sure. And have tried
> several websearches such as mplayer or openoffice. No results.
> Second and more serious problem is that when I find a proper rpm for my
> system on the net, the installation goes with no error messages from
> Gnorpm, but the programs do not work.
> I installed mplayer with needed packages, even got a icon in the foot
> menu. But mplayer will not work. When I type mplayer in the command line
> window, it says: 
> error while loading shared libraries: cannot open 
> shared object file: No such file or directory.
> I installed a libdivxdecore -file, but for no good.
> I also installed Java re, but now neither I or other programs
> (LimeWire-installer) can find it.

None of these sound like familiar bugs. Can you please file separate
bugzilla bugs for each distinct event so that I don't lose track of

> I installed the  openoffice rpm. But now I cant find it.

Try 'rpm -qa | grep -i openoffice' at the command line to get the exact
rpm name and then 'rpm -qi <pkg-name>' where <pkg-name> is the name you
got from the previous command. Then look at the line that says "Group".
That should show you the category it will appear under in gnorpm (unless
you are being bitten by bug #58448).

For what it's worth, I have also seen some strange differences between
gnorpm behaviour under older rpm versions and rpm-4.04 (the Red Hat 7.3
version). I haven't worked them all out yet, but it's getting there.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]