Video issues

I'm experiencing strange video behavior, using the following config:
IBM ThinkPad T20
Savage/IX video chip
12GB IBM Hard Drive
Solaris 8x86, build 10/01, recent patch cluster
Sun port of the XFree86 4.2.0 video drivers
GNOME 1.4, downloaded from Sun
Netscape 6.2.1 beta, downloaded from Sun
Logged in as root

A bit of background first: 8-bit, 16-bit and 24-bit all pass the kdmconfig
test in Solaris, and all work in CDE and Netscape 4.76. I have tried both
the Savage/IX and the VESA drivers, with no apparent difference.

This weird video shows up in both Netscape 6.2.1 beta and GNOME 1.4, but
only in 24-bit video. If I reduce the color depth to 16-bit or even 8-bit,
the weirdness goes away (as does the video quality). Someone on the Solaris
On Intel list pointed out a switch to try with Netscape 6.2.1, specifically
"--no-xshm", which worked a treat. This leads me to believe that the
weirdness might be coming from something to do with SHM Shared Memory, which
in turn led me to try to turn off the MIT-SHM Shared Memory Enabled option
in the Imlib Configuration Options | Rendering pane. I am able to turn the
button on and off, and save it to either the user or system level, at least
pressing one of the two save buttons doesn't immediately complain. However,
the save doesn't save. If I exit the Imlib Config Options screen, then go
back in, the setting I chose and saved has not been saved. If I set it, save
it, exit GNOME, restart GNOME, it hasn't been saved. If I go all the way
thru a cold boot, it hasn't been saved. How do I get a save to hold? Can I
set it from a command line by editing a file somewhere?

-Ian Duff.

ps, for those of you both curious what "weird" looks like, and with a Yahoo
account, I've posted digicam pictures of the screens here:
(sorry that Yahoo goes wild with URLs, this is one line)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]