Re: Gnome 1.4 Panel Launcher -- Netscape

   First off, great e-mail alias, Telsa. :-)  I first read The Hobbit 
and The Lord of the Rings over 25 years ago and reread them a couple 
of times, since.  I still consider them among the handful of best 
books I've ever read.  ...Oops -- guess this GNOME list is more 
concerned with its computer-accessory namesake than with those 
creatures who roamed Middle Earth, so I guess I better get back to my 
problem. :-)

   Sorry, I should have mentioned what software & versions I'm 
running -- which probably has a great deal to do with my problem.  
I'm using gnome 1.4 on top of FreeBSD 4.4-release.  (FBSD just 
released v4.5 a few days ago, so my OS is fairly modern.)  I'm 
running in Linux compatibility mode (whatever that entails -- I'm 
just learning) -- or so my system messages tell me when I boot the 
box...  Looking at my Linux-compatibility directories, it seems I 
have glibc-2.1.2 installed.  Checking for the xalf version gave me:

$ xalf -v    
xalf version 0.12
$ pkg_info -aI | grep xalf
xalf-0.12_1         X11 Application Launch Feedback

   I took a peak at 
and didn't see a newer version of that
On Friday 08 February 2002 05:54 am, hobbit aloss ukuu org uk wrote:
> ... And on behalf of the docs team,
> thank you for reading the docs. It's nice to think people read
> them after all the writing! :)

   And on behalf of the users, thank you for writing them!  I know 
that some people prefer to always hack their way through things (and 
I do, too, on occasion), but I like to be able to look up answers 
when I have questions.  (Of course, you've probably already gathered 
that I like to read. ;-) )

> The first suggestion I have is that you should try this as the
> line: "cd /usr/local/bin/netscape ; ./netscape" ...

   Simple enough... or so I thought.  I tried this command in the 
launcher and I found this in my ~/.xwm.msgs file when I tried the 

xalf: error: couldn't find cd in PATH

   True enough -- I don't have a "cd" executable file.  This system 
has only the shells' built-in cd's.  So, I faked it by dropping a 
"cd" script into my PATH (which simply calls the built-in cd with its 
arguments).  Per your suggestion, I redirected the stdout and stderr 
to a log file and the first error message (" failed...") went to 
that log file.  Now I'm left with only this error message in 

xalf: timeout launching /bin/sh

   Mind you, I'm running ksh and I didn't specify "/bin/sh" in my 
"cd" script.  The script contains a single line: "cd ${*}".  So, I 
wondered if the netscape wrapper's invocation of /bin/sh was the 
cause of this message.  So, I then changed the launcher's command 
line to:

cd /usr/local/netscape-4.51; ./communicator-4.51.bin >~/ns.out 2>&1 

   Still, the "" error message went to my ns.out log and the 
"xalf: timeout..." message went to ~/.xwm.msgs.

> I am basing this on a guess that the wrapper script you mention has
> relative paths in it...

   For what it's worth, I took a look at the wrapper and it has only 
absolute paths... not too important, it seems, since calling the 
executable directly has the same results.

> If you don't need xalf, the quick fix is to remove the package :)
> ...

   Before taking that step, I decided to try to figure out what xalf 
was doing with my commands.  So, I put my own "xalf" script earlier 
in my PATH and just had it print out its arguments.  It got "--title 
<Name field from launcher> /bin/sh -c <Command field from launcher>" 
as args.  I then simply modified my dummy xalf so that it would just 
strip off the title (in a roundabout way) and just run the command in 
a new shell.  The script looks like this:

command=`echo "${*}" | sed 's/.* -c //'`
/bin/sh -c "$command"

   So, I've effectively removed xalf, if not physically -- and my 
launchers now work like a charm... which begs the question of what 
xalf would buy me if it behaved with all of my app's.  So, I'm 
wondering if I'm better off using xalf with those things with which 
it woll work and, if so, how else I might get around this problem 
with running Netscape 4.51...
   Whether or not a cleaner fix can be found, thanks for stimulating 
the sinapses sufficiently to devise a workaround, Telsa.

"Tact is the ability to describe others as they see themselves." -- 
Abraham Lincoln (1809 - 1865)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]