Re: nautilus: No built-in viewers work

> Image, text and HTML-view in Nautilus fail on my Red Hat 7.1 system.
> When I double click on a file's icon, I get a dialogue box with the
> message
>      The Image view encountered
>      an error while starting up.
> (for images; a very similar message is printed for plain text or HTML.)
> I have tried "Raw Hide" binary RPM as well as a version I've built from
> CVS, with the same result.
> Any ideas what may be wrong?

The problem seems to be solved by

     xhost + localhost

I don't quite understand why, though, as I had no problems opening windows
etc., and "localhost" is included in /etc/X0.hosts (but I've seen
indications earlier that this doesn't have any effect.)

> How do I go about investigating the problem
> further? And who wrote this bloody useless error message???

... when

     Xlib: Client is not authorized to connect to Server

     Gtk-WARNING **: cannot open display: :0

or similar should have been used.

- Toralf

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]