Re: how to uninstall

On Fri, Jun 08, 2001 at 12:10:29PM -0400 or thereabouts, Ben FrantzDale wrote:
> First of all, may I ask why you don't want it? If there's something that
> can be easliy fixed you may not have to uninstall all of gnome.
> That said, you can uninstall packages from the command line with ``rpm
> -e packagename'' for any packages you don't want installed. ``rpm -qa''
> will give you a list of all packages installed (you probably want to
> pipe that to less ``rpm -qa|less'' so you can see everything)
> Be carefull what you uninstall that you don't break something important.

What he said, but an extra addition to that line: 

rpm -qa | grep gnome | less
rpm -qa | grep gnome > to-remove

Both will list anything with "gnome" in the package name. The second
will put them in a file called "to-remove" instead of splatting them
at your screen.

The other way to find the likely packages to remove is to look at
the FTP directory :) A likely candidate is the contents of
but note that some of that lot are for Gnome 1.4 and you won't have them.

Then this is the fun bit. The safest way is to construct a command
that removes all the packages without destroying all your dependencies,
which means don't use --force. Some people don't bother, but I am 
puritanical about not using it unless I have tried absolutely
everything first. I also tend to use --test when I'm messing about
with this, until I have something that allegedly works. 

So: rpm -e is the command, and you want them all on one line because
then it will sort the dependencies between those on the line out. If
it comes up with some error, it won't go ahead and do it. If you 
don't get your prompt back, and there's lots of disk activity, it's
working and your prompt will reappear when it's done. 

[hobbit aloss ~]$ rpm -e --test gnome-core gnome-libs gnome-utils
error: removing these packages would break dependencies:
	gnome-core >= 1.1.2 is needed by gnome-applets-1.2.1-5
	gnome-core = 1.2.1 is needed by gnome-core-devel-1.2.1-33
	gnome-core >= 1.0.0 is needed by gnome-lokkit-0.41-5
	gnome-core >= 1.2.1 is needed by gnome-netshield-0.2.0-1 is needed by gdict-0.8b-2

So "rpm -e --test gnome-core gnome-libs gnome-utils gnome-applets
gnome-core-devel gnome-lokkit gnome-netshield gdict" would be next, 
and you'll get more "foo is needed by bar". And eventually you'll
get something that doesn't have any dependencies. Or maybe just
one or two, at which stage it's up to you whether to apply --force

When you get no errors, remove the --test and go for it. 

This is all made -much- easier if you have something like Red Carpet
although I haven't specifically tried to get Red Carpet to remove Gnome
myself. If you have, use that. If not, start from the top :) 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]