Re: gnumeric hangs

Jens Finke wrote:

On Sun, 14 Jan 2001, David Shochat wrote:

When I try running gnumeric, it just hangs and after 15 seconds or so, I get a little alert box that says:

"gnumeric --sm-client-id <very long string of characters>
No response to the SaveYourself command.
The program may be slow, stopped, or broken.
You may wait for it to respond or remove it.

I click on the Remove Program button, but that just removes the alert (the gnumeric process is still there and has to be killed separately). So it neither kills nor removes it (what do they mean "remove" anyway?).

The gnome framework sends a "SaveYourself" signal to all running programs
at certain intervals. Every Gnome program should then save its current
state and settings. If you log out of gnome and login in later, all this
programs get started again with there saved settings (session management
If a program hangs (in this case Gnumeric) it doesn't respond to this
signal so the gnome framework pops up this alert box. The 'respond' and
'remove' options work on the internal list of running programs, which are
the ones to notify with the "SaveYourself" signal (so remove, removes
Gnumeric from the internal notification list of the session manager).  No
process gets killed by these actions.

Hope that clarifies the behaveiour a little bit.

To find out why Gnumeric hangs you should start it from a terminal and
look through the output messages.

Thank you very much for the information! I actually have "GTK+/Gnome Application Development" by Havoc Pennington and your response made me think of looking there, and there it is in section 5.5.

Unfortunately, there are no output messages whatsoever. I do see from "gnumeric --help" that there is a way to pass a debug level. What is the highest debug level I can pass to it? I just tried 10 which was a wild guess. I should point out that this problem does not appear to be specific to gnumeric. The same thing happens when I try to run gnome-hint (I posted a question about that a while back). But abiword runs fine. So does gmc. One more data point: I reinstalled the old version of gnumeric and it (now) has exactly the same bad behavior. So it makes me think there is something wrong with the "gnome framework" itself. I have tried reinstalling gnome-core (I seem to have the latest), but it installs without error and does not help. Is there something deeper than gnome-core I should try reinstalling? I also reinstalled the latest gtk+.

-- David

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]