gnorpm 0.95.1 compiling

While trying to compile gnorpm 0.95.1, configure returned the following:

checking for Fopen in -lrpmio... no
checking for rpmRunTransactions in -lrpm... no
checking for rpmdbFindByTriggeredBy in -lrpm... no
checking for rpmdbOpen in -lrpm... no
configure: error: can't find librpm (usually in rpm-devel package)

checking my system, I found:

root: /usr/src/tars/gnorpm-0.95.1 $ rpm -q rpm-devel

root: /usr/src/tars/gnorpm-0.95.1 $ l /usr/lib/librpm*
/usr/lib/librpm.a          /usr/lib/librpmbuild.a
/usr/lib/*        /usr/lib/*
/usr/lib/        /usr/lib/
/usr/lib/      /usr/lib/
/usr/lib/*  /usr/lib/*

Not being a programmer, I'm asking for pointers.  PLEASE don't
tell me I need rpm 4! (unless it's true, of course)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]