Re: Problems with URL Handler selection (how can I get gnome-moz-remote to call a newer ver. of Netscape?) --please help!

* Will Robinson ( wrote:
> Hash: SHA1
> I've recently installed RH 6.0 and although I was able to surf the
> web (after a bit of setting up) I noticed that the version of
> Netscape that was in the RH distro. was 4.51, while the newest ver.
> on Netscape's site was 4.61.  So I downloaded the 128-bit version of
> 4.61 for the linux 2.x kernel (glib version).  I ran its install
> script and the program installed fine.  I can run the program and
> browse with it normally.
> Here's my problem: apparently the new version of Netscape did not
> completely replace the old.  When I double-click on a dekstop icon
> which points to a URL (say, RedHat Documentation), the old Netscape
> (4.51) tries to pop up.  I think I've traced this problem to two
> places in the gnome controls: the MIME file type panel and the URL
> Handler control panel.  The new version of Netscape is installed in
> /usr/local/netscape (the default path for it), but changing the
> text/html action in the MIME settings to
> "/usr/local/netscape/netscape %f" prevents me from opening .html
> files from double-clicking.  I get a message which says "The file ...
> could not be opened with /usr/local/netscape/netscape %f."  Note that
> the original entry (which I've been forced to put back) in this MIME
> panel was "gnome-moz-remote --newwin %f."
> Also, and I think more importantly, I noticed that in the URL
> Handlers section, under default, the command "gnome-moz-remote
> - --newwin %s" was listed.  This was what
> appeared when I select "Netscape (new window)" from the pull-down
> menu above.  If I try to change the command in the "default" box to
> "/usr/local/netscape/netscape" with any combination of options, it
> has no effect; the panel simply reverts back to "gnome-moz-remote
> - --newwin %s" !!!  I've tried changing the setting both as root and as
> a regular user to no avail.
> It seems like it should be simple to perform such a minor upgrade. 
> Please tell me there's an easy answer...
> Thanks for your help,
> Will Robinson

Redhat ships with the netscape binary in /usr/bin
If you have installed the new version to a different path, then this
is the problem. Which copy gets loaded depends on the order of your
PATH variable. If you want to prevent confusion with the new version,
there are a number of things you could do

1) Remove /usr/bin/netscape and the symbolic links in /usr/bin to
navigator and communicator. This will make sure your new version is

2) Uninstall the old version with rpm -e netscape. (You should have
done this before installing a new copy through non-rpm means).

3) Re-install the new copy to the redhat path, overwriting the old

Your call. You could probably just su to root and rm
/usr/bin/netscape, but this isn't the _proper_ way.

If you do remove the /usr/bin/netscape binary, create a symbolic link
in there to your new copy.

ln -s /usr/local/netscape/netscape /usr/bin/netscape

    .^.     | Tom Gilbert, England | |
    /V\     |----------------------| |
   // \\    | Sites I recommend:   `--------------------------------|
  /(   )\   | |
   ^^-^^    `-------------------------------------------------------'

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]