SOLVED(?): october upgrade rpm weirdness?

I ran 'rpm -Uvh *rpm' one more time, and, of course, it returned a list of
packages that were already installed, then quit without installing any of 
the other packages.  I simply moved every rpm on the list to another
directory and ran 'rpm -Uvh *rpm' again.  This time all the remaining
packages were installed.

I'll probably follow Gregory's suggestion of rebuilding the rpm database.

Thanx to all who replied to my queries.  I appreciate it.

On Fri, 26 Nov 1999, Martin Brown wrote:

> Upon further inspection, it appears that 'rpm' is simply NOT working
> correctly.  Here are the steps I have performed while trying to upgrade
> RH6.1 gnome to october gnome:
> 1) download all october gnome rpm's, including devloper files, to a single
>    directory.
> 2) shutdown all gnome desktops
> 3) delete all home .gnome directories, including root's
> 4) as 'root', cd to october directory
> 5) execute 'rpm -Uvh *rpm':
>      a) no package names are displayed
>      b) no hash marks are seen
>      c) a single error condition is reported:
>          error: failed dependencies:
>          gtk+ = 1.2.5 is needed by gtk+-devel-1.2.5-2
> 6) random check of 3 or 4 packages ('rpm -q xxx') shows new package
>    versions.
> 7) as user, perform 'startx', and get a gnome desktop with what appeared
>    to be new features (which were probably just the origial default
>    settings I din't recognize).  At this point, I believe all is well
>    except for the single gtk+ error.
> 8) report this error to this list.
> 9) execute Gregory's suggestion, 'rpm -Uvh gtk+*rpm', to solve gtk+
>    problem, during which:
>      a) I see package name during install
>      b) I see hash marks during install
>      c) 'rpm -q gtk+' and 'rpm -q gtk+-devel' confirm installation
>      d) 'a' & 'b' above give me pause...
> 10) perform additional checks for new package installations, which come
>     up negative (original version numbers).  Hmm...
> 11) delete home .gnome directories again
> 12) as 'root', go back to october gnome directory and perform
>     'rpm -Uvh *rpm', which results in:
>         a) the listing of 8 packages with new version numbers that are
>            'already installed' (including the gtk+ ones)
>         b) no package names being listed as being "installed"
>         c) no hash marks being displayed
> 13) repeat #12 above a couple of additional times with the same result.
> >From all of the above I conclude 'rpm' is not working correctly.
> 'rpm' "seems" to be preprocessing and if it finds problems, including
> packages already installed, reports such then quits.
> Should I try: 'rpm -Uvhf *rpm'?
> Install each individually in the order downloaded?
> Other suggestions?
> Thank you to all for your help.
> -- 
>         FAQ: Frequently-Asked Questions at
>          To unsubscribe: mail with 
>                        "unsubscribe" as the Subject.

                           - Martin J. Brown, Jr. -

                             - BEAUDESIGN.COM -

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]