Re: imlib = 1.8 is needed by imlib-cfgeditor-1.8-5 (fwd)

On Thu, 21 Jan 1999, this is Zhao, Lenny wrote:
> Hi there, I am trying to install "gnome"


How are you trying to install GNOME?  I will guess you are using RPMs, but
it's not clear from your mail.

> I gotta this message when it starts to install:
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> GNOME install failed with the following error from rpm:
> failed dependencies: 
> imlib = 1.8 is needed by imlib-cfgeditor-1.8-5
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++

AFAIK, the package imlib-cfgeditor is depreciated, that is, you don't need
it anymore (and it won't work right with newer imlibs).  You can get rid
of it with:
  $ rpm -e imlib-cfgeditor

Also, if you are managing imlib with RPMs, you need to be clear on how you
do it.  The library package should be installed with:
  $ rpm -ivh imlib-<whatever>

That will keep the old version of imlib on your system, and add the new

> I use RedHat 5.2, I tried to reinstall "imlib" package, RPM won't do it
> bcs it is already exist(of course), All imlib(I think there are three of 
> them) are there, so it is still not working.

  $ rpm -q imlib
will list all the versions of imlib that RPM knows about.  If you think
that there are still more, do:
  $ locate libImlib

Note that many of the copies locate will list are merely symbolic links to
other copies.

Make sure you have one and only one copy of ""

> Please, someone help me!!!

I hope I've been of some help.  If I can be of more help, please send more
detail about your problems.

Best of Luck,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]