Re: installing gnome over Redhat 5.2

To provide some more useful information:
[root@ratbert installed]# rpm -V imlib
.M......   /usr/lib/
.M......   /usr/lib/
.M......   /usr/lib/
.M......   /usr/lib/
.M......   /usr/lib/
.M......   /usr/lib/
.M......   /usr/lib/
.M......   /usr/lib/
.M......   /usr/lib/
.M......   /usr/lib/

I haven't figured out what that means yet.  I tried changing the
permissions on all of those files to 777 and that didn't help.

Program received signal SIGSEGV, Segmentation fault.
0x80ca340 in ?? ()
(gdb) backtrace
#0  0x80ca340 in ?? ()
#1  0x40515066 in _IO_vfprintf (s=0x405b1900, 
    format=0x401cfc89 "gdk_imlib ERROR: Cannot load image: %s\nAll
fallbacks failed.\n", ap=0xbffff7d8) at vfprintf.c:1018
#2  0x4051cdd7 in fprintf (stream=0x405b1900, 
    format=0x401cfc89 "gdk_imlib ERROR: Cannot load image: %s\nAll
fallbacks failed.\n") at fprintf.c:32
#3  0x401b4dc0 in gdk_imlib_load_image (
    file=0x80cd108 "/usr/share/pixmaps/tiles/tile-normal-up.png") at
#4  0x80707cb in loadup_file ()
#5  0x8070a19 in button_widget_load_tile ()
#6  0x8055d2b in apply_global_config ()
#7  0x8057821 in load_up_globals ()
#8  0x805249d in main ()
#9  0x404e9877 in __libc_start_main (main=0x80522d0 <main>, argc=1, 
    argv=0xbffff938, init=0x8050728 <_init>, fini=0x807594c <_fini>, 
    rtld_fini=0x4000aa00 <_dl_fini>, stack_end=0xbffff934)
    at ../sysdeps/generic/libc-start.c:78

After trying another copy of imlib1.9 with the same result, I tried
going back to imlib 1.8.  At which point the panel actually tries to
start, but fails continuously in the following loop about 6 times, with
intersparsed 'gnome-pager error' messages.

SOCKET XID: 7400092

register ext: 80D73D8
register ext->info: 80D74F0
add callback ext: 80D73D8
add callback ext: 80D73D8


register ext: 80E9D50
register ext->info: 80E9E78
add callback ext: 80E9D50
add callback ext: 80E9D50

Gdk-WARNING **: GdkWindow 0x6800032 unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x6800017 unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x6800016 unexpectedly destroyed

Gdk-WARNING **: GdkWindow 0x6800005 unexpectedly destroyed

Gtk-CRITICAL **: file gtkwidget.c: line 1375 (gtk_widget_destroy):
assertion `GT
K_IS_WIDGET (widget)' failed.

Gtk-CRITICAL **: file gtkwidget.c: line 1375 (gtk_widget_destroy):
assertion `GT
K_IS_WIDGET (widget)' failed.

When I try to run 'panel' again, it just sits there.


Charlie Younghusband wrote:
> Mike Stoddart wrote:
> >
> > Is it possible to install the latest Gnome over a clean Redhat 5.2
> > system?  I tried it and it didn't work, complaining about loads of
> > libraries.  So I tried to fix things by hands, and I've made it worse.
> > Is there any way to get out of this fix, and get a working gnome
> > system?  Ive been trying for days to get it to work.  To say Im pissed
> > off is an understatement.
> Ditto here.  I had things generally working with 0.99.0 (I'm using RH
> 5.1).  While upgrading other things, I thought I'd upgrade to 0.90.2.
> Downloaded all of the required libraries, and found myself with really
> stupid cyclical dependencies.  Last time I was able to --nodep my way
> through it, but now panel segfaults on startup.  The only remaining
> problem according to rpm is:
> [root@ratbert rpm]# rpm -V gnome-guile
> Unsatisfied dependencies for gnome-guile-0.27-1:,
> Which I can't figure out how to fix.
> I haven't had any luck going backwards (short of removing most rpms by
> hand), and I don't have the disk space to do the tarball installation.
> To be harsh for a second, I think whoever created the RPMS should be
> shot.  Why not a big gnome-0.99-2.rpm?  Not including gnumeric etc. but
> all of the basic apps required to run the panel anyway.
> Does anybody have a suggestion as to what I can do other than sit, stare
> at my screen and pout?  How do I figure out what is causing the
> segfault?
> Charlie
> Relevant RPMs that I have (not that you want to copy me!) are:
> gnome-objc-devel-0.99.1-2
> gnome-network-0.13-1998050420
> gnome-linuxconf-0.13-17rh
> gnome-audio-0.1-1
> gnome-rh5.2-release-notes-1.0-6
> gnome-objc-0.99.1-2
> gnome-guile-devel-0.27-1
> gnome-imglib-0.30-1998100612
> gnome-imglib-0.13-1998050617
> libPropList-0.7.1gnome-1
> gnome-rh5.1-release-notes-1.0-5
> gnome-users-guide-0.99.0-1
> gnome-games-devel-0.99.1-2
> gnome-guile-0.27-1
> gnome-media-0.99.1-2
> gnome-libs-0.99.2-1
> gnome-games-0.99.1-1
> gnome-core-devel-0.99.2-1
> gnome-utils-0.99.1-2
> gnome-pim-0.99.0-2
> gnome-core-0.99.2-2
> gnome-libs-devel-0.99.2-1
> gtk+-1.1.12-1
> gtk+10-1.0.6-2
> gtk+-perl-0.2-4
> gtk-engines-0.1-2
> gtk+-devel-1.1.12-1
> imlib-cfgeditor-1.9.0-1
> imlib-devel-1.6-1
> imlib-1.9.0-1
> libgtop-devel-0.99.2-1
> libgtop-0.99.2-1
> gtop-0.99.2-2
> libgtop-examples-0.99.2-1
> libxml-devel-0.99-2
> libxml-0.99-2
> mcserv-4.5.6-1
> gmc-4.5.6-1
> mc-4.5.6-1
> ORBit-0.3.91-2
> ORBit-devel-0.3.91-2
> control-center-devel-0.99.1-4
> control-center-0.99.1-4
> esound-0.2.7-1.i386.rpm
> fnlib-0.4-1.i386.rpm
> fnlib-devel-0.4-1.i386.rpm
> freetype-1.1-5.i386.rpm
> glib-1.1.12-1
> glib10-1.0.6-2
> --
> Charlie Younghusband
> Network Systems Programmer
> Xiphos Technologies
> 514-848-9640
> --
>         FAQ: Frequently-Asked Questions at
>          To unsubscribe: mail with
>                        "unsubscribe" as the Subject.

Charlie Younghusband
Network Systems Programmer
Xiphos Technologies

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]