Re: Compiling GTK+

Thanks for replying so quickly, and sorry that it so long to write back.
I became a father in the meantime and it took a bit longer than I had

Anyway: I found my aclocal file and it doesn't contain the gettext.m4
that gtk+/ wants. I have version automake 1.3b. Is this
already outdated? I looked in the source directory (and of course in the
m4 subdirectory of the source directory and there was no gettext.m4.
Actually, I searched the whole hard drive after installing automake. No
gettext.m4 anywhere.

And as to gettext itself: I downloaded version 0.10.35, but I still
can't install it. I run ./configure in the source directory, then 'make'
- and here, I get several errors. I attached the output of 'make 2>
err.txt' in a separate file. Do you have any idea what I could have done
wrong? I'm running Slackware with kernel version 2.0.35 - and I
certainly don't feel like going back to RedHat just to be able to run
Gnome applications.


Gleef wrote:
> On Tue, 12 Jan 1999, Juergen Fiedler wrote:
> > Hello,
> >
> > I'm trying to install Gnome and I'm running into some problems. As
> > recommended at, I downloaded
> > glib using CVS. I compiled and installed it (including the changes to
> > - everything worked fine. But then I tried to compile gtk+ -
> > and even while running './ --prefix='/usr/gnome'', I got a
> > bunch of messages - the log file with the first few is attached to this
> > message.  Basically, autogen was trying to get macro files from
> > /usr/share/aclocal, but this directory doesn't even exist.
> Try running this:
>   #  which aclocal |xargs grep prefix
>   $prefix = "/usr";
>   $acdir = "${prefix}/share/aclocal";
>               # Macro not found, but AM_ prefix found.
>               # Macro not found, but AM_ prefix found.
> If prefix is "/usr/local", then the macros should be in  /usr/local/share/aclocal.
> Most of us have them in /usr/share/aclocal, but things should as long they
> are where aclocal looks for them.
> If the above command results in a blank, you NEED aclocal to install GNOME
> from CVS.  It should be part of the automake package you installed in the
> Getting Started section of the webpage you referred to.  While you're at
> it, make sure you have all the rest of that.
> > I think it might have to do with the fact that I don't have gettext
> > installed (I tried, but the gettext makefile didn't work - but I don't
> > really want internationalisation, anyway).
> Gettext is no longer an option for building from CVS, you need it whether
> or not you want internationalization.  Also, the web page you refer to is
> a little out of date.  You need gettext version 0.10.35 from
>  Make sure all three m4 files from gettext files go in
> the share/aclocal directory.
> Best of Luck,
> -Gleef
> --
>         FAQ: Frequently-Asked Questions at
>          To unsubscribe: mail with
>                        "unsubscribe" as the Subject.
gettextp.o: In function `main':
/usr/extras/gettext-0.10.35/src/gettextp.c:95: undefined reference to `bindtextdomain'
/usr/extras/gettext-0.10.35/src/gettextp.c:96: undefined reference to `textdomain'
/usr/extras/gettext-0.10.35/src/gettextp.c:134: undefined reference to `gettext'
/usr/extras/gettext-0.10.35/src/gettextp.c:139: undefined reference to `gettext'
/usr/extras/gettext-0.10.35/src/gettextp.c:154: undefined reference to `gettext'
/usr/extras/gettext-0.10.35/src/gettextp.c:164: undefined reference to `gettext'
gettextp.o: In function `usage':
/usr/extras/gettext-0.10.35/src/gettextp.c:228: undefined reference to `gettext'
gettextp.o:/usr/extras/gettext-0.10.35/src/gettextp.c:233: more undefined references to `gettext' follow
make[2]: *** [gettext] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]