Re: Compiling GTK+

On Tue, 12 Jan 1999, Juergen Fiedler wrote:
> Hello,
> I'm trying to install Gnome and I'm running into some problems. As
> recommended at, I downloaded
> glib using CVS. I compiled and installed it (including the changes to
> - everything worked fine. But then I tried to compile gtk+ -
> and even while running './ --prefix='/usr/gnome'', I got a
> bunch of messages - the log file with the first few is attached to this
> message.  Basically, autogen was trying to get macro files from
> /usr/share/aclocal, but this directory doesn't even exist.

Try running this:
  #  which aclocal |xargs grep prefix
  $prefix = "/usr";
  $acdir = "${prefix}/share/aclocal";
              # Macro not found, but AM_ prefix found.
              # Macro not found, but AM_ prefix found.

If prefix is "/usr/local", then the macros should be in  /usr/local/share/aclocal.
Most of us have them in /usr/share/aclocal, but things should as long they
are where aclocal looks for them.

If the above command results in a blank, you NEED aclocal to install GNOME
from CVS.  It should be part of the automake package you installed in the
Getting Started section of the webpage you referred to.  While you're at
it, make sure you have all the rest of that.

> I think it might have to do with the fact that I don't have gettext
> installed (I tried, but the gettext makefile didn't work - but I don't
> really want internationalisation, anyway).

Gettext is no longer an option for building from CVS, you need it whether 
or not you want internationalization.  Also, the web page you refer to is
a little out of date.  You need gettext version 0.10.35 from  Make sure all three m4 files from gettext files go in
the share/aclocal directory.

Best of Luck,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]