Re: [rebecca ore op net: drive-mount applet]

On Sun, Jan 17, 1999 at 12:40:56AM -0500, Elliot Lee wrote:
> On Sat, 16 Jan 1999, Miguel de Icaza wrote:
> > ------- Start of forwarded message -------
> > Date: Sat, 16 Jan 1999 03:16:50 -0500
> > From: Rebecca Ore <>
> > To: Gnome-list <>
> > Subject: drive-mount applet
> > Mail-Followup-To: Gnome-list <>
> > Content-Type: text/plain; charset=us-ascii
> > X-just-a-test: testing
> > 
> > It doesn't get as far as a core dump this time.  I'm running it compiled
> > as per the Jan. 15 instructions on the Gnome site, with control-panel
> > revised make files but still using 0.99 (saw that 0.99.1 was released).
> This bug has been fixed since the 0.99 release. Please get the latest of
> everything before reporting bugs :)

It isn't fixed in core 0.99.3, which is what I've been getting the core
dumps on.

And broken in gnome-core 0.99.0, 0.99.1, 0.99.2.  Thank you very much.  It was
working just fine in 0.30.

Kernel 2.0.36, all required upgrades, worked with Martin on one thing
that was keeping libgtop from building.  So you have a bug that you
fixed in cvs (I don't think you guys ever build the tarballs to test
them because of some of the goofy problems with them, like the whole
business in control-panel.  

If it has been fixed in cvs, you should really consider incorporating
those changes into the tarballs.

And especially when everything else that was a fragile applet seems to
be working, like mini-commander.

I'll report it until it's fixed in whichever release comes out next.

It is broken, it has been broken since the release of 0.99.0, and it
was not broken, for me, in 0.30.  Sorry I can't give you a patch, or
build a tarball from cvs source, yet.

Please make the fixes in the next tarball.  I'll be willing to test
patches.  I have been upgrading and building from
0.99.0 on through 0.99.3, and this one is getting worse, not better.

I can't get it up to change the properties now.  I was using it to to a
mount of a zip drive.

I will try to make my reports even more thorough if you want. 

Everyone else, this is the sort of reply I don't think anyone should be
giving anyone willing to beta-test things.  If I'm causing the problem,
it's nothing as obvious as not upgrading to 0.99.3, with all the
trimmings.  I've got a ruptured cervical disc and I can spend my time on
things that are less risky than building every released tarball that
comes out.  Especially when I thought we'd gotten over this business of
making snap judgments about people who are only testing the tarball
releases.  So if a developer has an attitude about getting bug reports
from the peanut gallery, it might be well to make double certain that
the thing works from tarballs.

I've been doing beta testing for open source projects for over a year
and went through this with the first group -- like what did I do wrong.
It's possible I did do something wrong, but sheesh, not that I wasn't
using all the resources available to me at Gnome site.  I'm working with
RedHat 5.1, the not-tested varient, but with the recommended upgrades.
I follow this list and apply the patches that I see.  Since I've been a
despammer, I'm used to being attacked, but I'm really not used to being
condescended to.  And I didn't send in bug reports when there were
things upstream of the applet that might have been contributing to the
problem.  So now, those things do appear to be fixed, and this thing
still shows up, in gnome-core, and it has gotten worse since
0.99.2, not better (I was able to at least see the drive-mount applet
even though it came up in two instances before dumping core when I tried
to adjust the preferences to the zip drive and mount point).

So, I'll go back and rebuild it again.

And if it works after I recompile, I'll apologize for
this rant.  If not, I'll check back for the post on all the things I'm
suppose to put in a bug report and put them all in, and report the bug
again, with trimmings.

My intuitions as a beta tester are that the people making the tarballs
don't build a system from them before they release them.  And some
things are being built on systems that aren't likely to be the average
systems.  If it required a beta kernel to compile and work without
dumping instant core, I think this is a bug for many end users.

After my first swing through here with a bug, I got ranted at for not
being properly appreciatiative of the developer's efforts, and I got
some email from some developers thanking me for being part of the team.
I'll be happy to make sure that I just report bugs for those developers
if other developers find bug reports from people who can't do patches to
be offensive.  I can just not bother the other guys if that would make
everyone happier.

By the way, the bug in majhong is fixed.  Thanks.

Rebecca Ore

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]