Compiling GTK+


I'm trying to install Gnome and I'm running into some problems. As
recommended at, I downloaded
glib using CVS. I compiled and installed it (including the changes to - everything worked fine. But then I tried to compile gtk+ -
and even while running './ --prefix='/usr/gnome'', I got a
bunch of messages - the log file with the first few is attached to this
message. Basically, autogen was trying to get macro files from
/usr/share/aclocal, but this directory doesn't even exist.
I think it might have to do with the fact that I don't have gettext
installed (I tried, but the gettext makefile didn't work - but I don't
really want internationalisation, anyway).
Could someone please help me to get this thing straightened out?

WARNING: aclocal's directory is /usr/local/share/aclocal, but...
         no file /usr/local/share/aclocal/gettext.m4
         You may see fatal macro warnings below.
         If these files are installed in /some/dir, set the ACLOCAL_FLAGS 
         environment variable to "-I /some/dir", or install

Running gettextize...  Ignore non-fatal messages.
loading cache ./config.cache

Now type 'make' to compile Gtk+.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]