Re: Is Imlib the right file to be looking at?

On Tue, 12 Jan 1999, kiwiPete ( Peter Cague, New Zealand ) wrote:

> I've tried to reinstall imlib to fix the shared lib problem ( didn't
> work)
> gnome-run: error in loading shaerd libraries
> /usr/local/lib/ undefined symbol:
> gdk_imlib_set_cache_info

What program are you trying to run?  Find the actual binary, and run ldd
on it.  For example:
  $ ldd /opt/gnome/bin/gnomine => /opt/gnome/lib/ (0x4001c000) => /opt/gnome/lib/ (0x400db000) => /opt/gnome/lib/ (0x400ea000) => /usr/lib/ (0x40117000) => /usr/lib/ (0x40135000) => /usr/lib/ (0x40160000) => /usr/lib/ (0x40167000) => /usr/lib/ (0x40183000) => /usr/X11R6/lib/ (0x40192000) => /usr/X11R6/lib/ (0x4019c000) => /opt/gnome/lib/ (0x401b4000) => /opt/gnome/lib/ (0x402d9000) => /opt/gnome/lib/ (0x4030c000) => /usr/X11R6/lib/ (0x4030f000) => /usr/X11R6/lib/ (0x4031b000) => /lib/ (0x403c0000) => /opt/gnome/lib/ (0x403dc000) => /opt/gnome/lib/ (0x403f0000) => /lib/ (0x403f7000) => /opt/gnome/lib/ (0x40430000) => /lib/ (0x40452000) => /lib/ (0x40456000)
  /lib/ => /lib/ (0x40000000)

Replace /opt/gnome with whatever prefix you use, or "/usr/local" if you
don't use any.  Any line saying "not found" needs to be worked on.

Incidentally, gdk_imlib_set_cache_info is in, which should
be part of the imlib package.  Make sure that the line for libgdk_imlib in
the above ldd is pointing to the right location.  If you have two 
different versions on your machine, it might be going to the wrong one.
Make sure you have one and only one copy of on your

> Could it be I should reinstall the Gnome libs even?

If your are sure that libgdk_imlib is in properly, reinstalling gnome-libs 
would be the next step.  Make sure to "make distclean" and "rm config.cache" 
in your gnome-libs source directory before recompiling.
Best of Luck,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]