Re: gnome panel

> On Fri, Jan 08, 1999 at 08:33:03PM +0100, Ronald de Man wrote:
> > >   I'm having this problem with the latest released software -
> > > gnome-core-0.99.2, gnome-libs-0.99.2, glib-1.1.12, gtk-1.1.12, etc.  Also
> > > using Linux 2.1.132, glibc-2.0.7, on a P166.  How it happens seems to
> > > change, but the end product is the same - death to my applets.  Or at
> > > least some.  I'm running the clock, the fish, modem lights, and mailcheck. 
> > > Clock seems to be the one bombing out, and generally takes mailcheck with
> > > it.  The other two seem to be working fine.. everything has been pretty
> > > stable since I've stopped trying to load clock.
> > 
> > With current CVS I can still produce the problem. The way the panel
> > behaves at startup seems to be somewhat random, although I'm strongly
> > suspecting the mailcheck/clock applet now. Running the panel from the
> > commandline and not from gnome-session, the problem seems to be gone
> > now.
> the more and more I think about it ... the more and more I think it's
> a libgnorba race .... I added some race prevention to panel, but without
> the syncronious startup which kind of sucked anyhow ... we can't
> completely shield libgnorba ... and I guess it gets races
> get the absolute newest cvs panel (I've done some stuff yesterday), and
> see if it still happens
> George

I haven't yet tried the absolute newest cvs panel, but I did try
the absolute latest kernel (2.2.0-pre6). Starting up the panel
from gnome-session a couple of times worked fine now! The clock
and mailcheck applets are there, and I get exactly one panel.

Unfortunately 2.2.0-pre6 is telling me that ttyS2 is busy, which is
my modem, so before I've figured out what's wrong I'm back to using
2.0.36. And back to the multiple panels, which shows it's really
the new kernel that makes the difference for me.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]