Re: undefined symbol: --bzero

If I remeber correctly, __bzero is a symbol exported by glibc2.1.  If you're
using glibc2.0 (which you should be with a stock RH 5.2 installation, I
think -- Debian user), then installing glibc 2.1 should fix this.

But I've been wrong more than once . . .

Dave Neuer

-----Original Message-----
From: Hamish <>
To: Gnome Mailing List <>
Date: Friday, April 23, 1999 12:32 PM
Subject: undefined symbol: --bzero

>Hi Guys,
>        My name is Hamish Tree and I am new to this list, so I would
>firstly like to say hello to everyone and especially to the developers
>of Gnome & Enlightenment. You guys are rocking the Gnu world! :-)
>I am also very new to Linux, however I enjoy it so much, that I only
>wish I had the technical skills to use it more effectively. I'm afraid I
>still need to lean on Bill for support in my everyday online work, due
>to the fact that my attempts to configure PPP in Linux, have so far been
>decidedly unsuccessful.
>Ok, enough introduction. I can hear all the programmers on this list
>muttering under their breath already. I know you guys like dealing in
>straight facts.
>So, here's my problem. I recently downloaded the entire user rpm suite
>for Gnome 1.x, as updated by Red Hat Labs on April 14th. I also
>installed X-Screensaver, Guile and UMB-Scheme from my Red Hat 5.2 CD. I
>have tried numerous times to install Gnome/Enlightenment over the past
>few days, using both 'rpm -Uvh *rpm' & 'Glint' under X. Both techniques
>produce the same results.
>Enlightenment seems to be running ok, however all of the desktop icons,
>which were working in earlier 0.15x releases are absent and I have been
>unable to bring them up with 'Cntrl+Alt+C or B'. Also when I try to
>execute the Gnome Panel, Editor, GMC etc, I receive the following error;
>Error in loading shared libraries:/usr/lib/ undefined
>symbol: --bzero
>I have tried verifying different libraries using GnomeRPM, but as far as
>I can see, everything seems to be ok. I have re-installed Linux as a
>'Workstation', a 'Server' and a 'Custom' install minus all Gnome related
>libraries. All variations produce the identical error.
>Does anybody recognize this problem? I have searched extensively
>throughout the various news group databases and Gnome Mailing List
>archives, but apparently I am the only person in the world who has this
>I have re-installed Linux 11 times in the past three days and to say the
>least, I am starting to get a little frustrated.
>Thank you very much in advance for any help I may receive.
>        FAQ: Frequently-Asked Questions at
>         To unsubscribe: mail with
>                       "unsubscribe" as the Subject.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]