Re: Java Bindings



>> I'd just like to announce that I'm doing some development to create Java
>> bindings for Gnome/Gtk. Things are really crude now, but I wanted to inform
>> gnome-list that something was happening about Java support.
>
>Wow!  That is so cool!

Thanks !

>I would like to suggest to keep the same naming conventions that are
>used in Gtk for the Java bindings.

For instance, with the current converter gtk_window_set_title(..) is
translated to:

package gtk;

class Window
{
   void setTitle(String title)
   ...

Nearly every Java application or library uses the method naming scheme from
Sun JavaSoft (no underscore, inner words capitalized), so I'm a bit
reluctant about using the C underscore naming convention, the Java code
would look really strange. Also, some development tools relies on these
conventions to provide additional features (i.e. JavaBeans "patterns").

But it is true that I might have been a bit extremist with the renaming of
GtkWindow into gtk.Window, and gtk.GtkWindow is probably a better idea and
would also avoid any confusion with java.awt.Window (while quite unlikely
by the obligation to use an "import gtk.*" or "import java.awt.*" )

I can add a flag in the next converter to toggle this naming behavior and
default it to the gtk.GtkWindow scheme.

Ol.
--
Olivier Gutknecht     ...      Laboratoire d'Informatique, Robotique
gutkneco@lirmm.fr     ...      et Micro-Electronique de Montpellier.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]