Serious problem with GTK from CVS


Every program that uses GTK version 1.1 crashes
with a sigsegv error. This has gone on for weeks now.

I am trying to use the CVS version of GTK.
I always run 'cvs -z3 update' and then './autogen' and 'make install'
and every time the testgtk program gets a sigsegv error.
I get very few warnings when compiling GTK.

I have experimented a little and found that the error happens
on the line "gtk_container_add(window, box1)" or something
like that, right after the program starts but before the main window

I'm using Linux on a PowerMac clone with kernel version 2.1.103 from I think I'm using the most recent software
from the LinuxPPC project.
I just compiled gcc 2.8.1 because I thought a new compiler could
fix it, but it still doesn't work.
I've already tried doing a "make clean" and recompiling many times.
The testglib program works, so glib is fine.

Ian Farmer

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]