Re: 'About' versus 'About...'

sun wrote:
> <laugh> thanks for the input, bruce. what about it kids, shall we try to
> nail down this relatively small corner of the style guide? i'll try to
> state concisely what seems to make the best sense so far:
> Menu items that open dialogs which require additional user information
> shall indicate it with a "..." after the label; however, menu items that
> open dialogs which only display information shall not. Further, all
> dialogs which require additional user information shall include a
> "Cancel" button which shall exit the dialog without making any changes
> to the application or document.
> Examples: the "Save As" menu entry should actually look like "Save
> As..." and the "About" menu entry in the "Help" menu should just read
> "About".
> (stolen & doctored from the current style guide)

Some menu items should clearly have the '...', e.g.
"Save As..." as you mention, while other items should
clearly not, e.g. "Copy".

I disagree on the case of message boxes, however, even
though I must admit that my reasoning is not very "strong",
but still gives me a 60% preference of using the '...'
in cases of message boxes like "About [appname]..." and
similar thing :)

The reason why I thing the '...' _should_ be used in such
cases is the expected user interaction pattern.  In the
case of an about box, it is "most likely" that the user
will indeed exit the message box _immidiately_ before doing
anything else.  The '...' would indicate a high likelyhood
for such a behavior, and give the user a clue about it.

A very different case would be a "system load indicator"
window/box, while it could just as well be used in a view/
click-away manner, conceptually it provides added usefulness
if remaining open.

Given above argumentation, I do beleive that windows
which are "conceptually" modal should only be used
sparingly which is in line w/ our previous discussion
on reducing the number of annoying message boxes.

In case you don't think this makes enough sense (would be a pitty),
I would suggest to use "About [appname]..." resp.
"About [appname]" where appname is optional but recommended.

As another suggestion, IMO the remaining "was-modal"
message boxes should contained one button which
should not be labeled "Ok" because this could make
the user think that "(positive) confirmation" is meant,
while it's actually just meaning "go away".

Possible labels would be "Dismiss", "Continue",
"Hide" or "Close", and I prefer "Dismiss" followed
by "Continue" :O)

Comments ?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]