Re: [gnome-db] DataPivot on libgda-4.2?

That I means. As Vivien state 4.2 branch will be maintened but no 4.4 will be released. Then we need to remove any new API on 4.2.

2011/9/21 Murray Cumming <murrayc murrayc com>
On Wed, 2011-09-21 at 20:58 +0200, Vivien Malerba wrote:
> On 21 September 2011 20:50, Daniel Espinosa <esodan gmail com> wrote:
>         Why add new features to 4.2?
>         I'm improving 4.2 branch for bindings, but not adding new
>         features. Latest commits have added GdaDataPivot, and I think
>         4.2 branch just need to be modified for security, stability
>         and bug fixing.
>         New features must be on libgda-5.0, I think.
> From my point of view, I consider the 4.2 and 5.0 branches similar in
> features, they simply differ because the 5.0 is geared towards GTK3
> and its ecosystem. I plan to have some maintenance only in the 4.2
> branch once the 5.0 version is out (for which I would like to inclde
> SqlCipher 2.0).
> However, if you really consider it difficule, I can change that and
> remove the GdaDataPivot new feature in the upcoming 4.2.10 version.

4.2 plus new API would be 4.3/4.4.

murrayc murrayc com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]