Re: [gnome-db] Porting libgda-ui to GTK+3?

On 14 June 2010 11:46, Murray Cumming <murrayc murrayc com> wrote:
> On Sun, 2010-06-13 at 20:01 +0200, Murray Cumming wrote:
>> On Sun, 2010-06-13 at 16:14 +0200, Vivien Malerba wrote:
>> > when 4.2 is released, do a 4.2 to work with GTK2 a,d a 5.0 to work with GTK3
>> That sounds reasonable.
>> However, unless that libgdaui-5.0 will be available for GNOME 3.0, it
>> will require GNOME 3.0 to depend on both gtk+-2.0 and gtk+-3.0.
> Anyway, I've created a gtk3 branch that uses GTK+3 and the appropriate
> versions of gtksourceview and goocanvas:
> I didn't need to make any code changes.

I would have prefered to make those modifications in the msater
branch, and create a LIBGDA_4_2 branch for the same code but with the
GTK3 dependency.

I'll modify it to:
* rename the generated file with 5.0 instead of 4.0 to make this
version parallel installable with the 4.0
* remove the unnecessary code which was there to maintain the
requirements to GTK+ 2.12


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]