Re: [gnome-db] Porting libgda-ui to GTK+3?

On Sun, 2010-06-13 at 16:14 +0200, Vivien Malerba wrote:
> On 13 June 2010 14:59, Murray Cumming <murrayc murrayc com> wrote:
> > May I make libgda-ui use GTK+ 3 instead of GTK+ 2?
> >
> > I don't think libgda-ui has had a stable release yet, so I don't see a
> > need to change it's ABI name (.pc file, library name, includes
> > directory, etc).
> >
> > As ever, I think things would be much simpler if libgda-ui was not in
> > the same module as libgda.
> I know, but I already explained the design choices, and I don't want
> to change this now.
> I was thinking about the following solution for the GTK3 change:
> * create a branch for what will be the 4.2 version
> * in master, change the requirements to GTK3 and associated libraries versions
> * maintain both branches in sync with regards to evolutions
> when 4.2 is released, do a 4.2 to work with GTK2 a,d a 5.0 to work with GTK3

That sounds reasonable.

However, unless that libgdaui-5.0 will be available for GNOME 3.0, it
will require GNOME 3.0 to depend on both gtk+-2.0 and gtk+-3.0.

murrayc murrayc com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]