Re: [gnome-db] New gda_parse_string convenient function

On Wed, 2010-06-09 at 20:21 -0500, Daniel Espinosa wrote:
> Please find attached a new gda_parse_string convenient function. I'm
> using in some code and I think any buddy needs to parse a SQL command
> string and get its parameters all the time, this function helps on it.

gda_parse_string() is an awfully generic name for this. Surely it should
at least mention sql in the name.

But all of these "easy" functions really need to be moved into their
appropriate classes. They currently break object-orientation completely
and unnecessarily.

For instance, this convenience function should probably be
gda_sql_parser_parse_string_for_connection() or

murrayc murrayc com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]