Re: [gnome-db] Some strange crash with gnome-db-0.2.95

* luned́ 25 febbraio 2002, alle 01:20, Rodrigo Moya scrive:
> > Installing them I got no dependacy problems. As I ran gnome-db the interface ran well. So I called the connection manager and selected the database that I wanted to connect to (after filling it in the manager section). Then I got an error message which told me "connectDBStart() -- connect() failed: Connection refused. Is the postmaster running (with -i) at ''and accepting connections on TCP/IP port 5432?". Error message -> 0
> > 
> > Whne I upgraded to postgresql I set the pg_hda.conf entry for so this is not the problem. I didn't do any network corrections since I upgraded so I don't think it's a postmaster refuseing the request unless the new installation of postgresql dosn't start the postmaster correctly. As a matter of fact I noticed that during boot the postmaster is not started. I have to start it manually by /etc/rc.d/init.d/postgresql start on my RH7.1. But anyway, when I start it pgsql connects to my databases correctly and gives me no problems.
> > 
> this seems something to do with the way you're specifying the parameters
> in the GNOME-DB manager. What values are you using for connecting to
> postgres from GNOME-DB?

Exactly the same values I used with 0.2.94

> > If I call the connection dialog to connect to the database for a second time it crashes a the window gets locked. I have to kill it with xkill.
> > 
> > I wanted to try running through gdb but forgot how to get a dump of the execution (I'm not a programmer but I think this could have helped you guys understand what's going wrong ;-))
> >
> it is the 'bt' command. You just have to run it when the program
> crashes, and send us the output.

Well. I tried it. when I gave gdb the 'bt' command it told me 'no stack'. As a matter of fact the crash is rather strange. It isn't the main window that locks but it's the connection windows that locks on the second try and I have to kill it with xkill. SO the main gnomedb-fe window works correctly but I can't recall the connection window. Exiting the program by the file menu gives me 'program exited normally' in gdb. 
> > Hope someone helps me out. I was getting used to this nice software and pgsql was  getting rather small.
> > 
> > BTW. I wanted to try building the source rpms but got discouraged but the numerous dependacies:
> > 
> > [root gaia gnome-db-0.2.95]# rpm --rebuild libgda-0.2.95-1mdk.src.rpm 
> > Installing libgda-0.2.95-1mdk.src.rpm
> > error: failed build dependencies:
> > 	MySQL-devel is needed by libgda-0.2.95-1mdk
> > 	libxslt-devel is needed by libgda-0.2.95-1mdk
> > 	popt-devel is needed by libgda-0.2.95-1mdk
> > 	postgresql-devel is needed by libgda-0.2.95-1mdk
> > 
> > Why do I need MySQL when I don't want to use it?
> > 
> to build the different providers. But you just need the devel libraries,
> not the database engine. If you are going to build the RPMs, you'll need
> those -devel packages installed.
Well, please read my previus message. I only got round a compile failure by installing the Mysql DB engine and shared librearies but then got stuck with interbase dependancy problems during compilation time and not during execution on 'rpm --rebuild ligda.....'

> And heh, that mdk package is wrong. libxslt-devel shouldn't even be a
> dependency, since it's not used anymore.

Yes, the good gnomedb packages I downloaded from the gnomedb site don't recall those dependancies...

                 Antonio Gennarini
                Crecchio, CH - ITALY
Earth Science student at University "G. D'Annunzio".
     Join th GNU generation, start from LINUX.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]