[gnome-db] Some strange crash with gnome-db-0.2.95


I just updated to postresql 7.1.3-2 and found out that gnome-db-0.2.94 crashed on my system (while psql worked fine). So I decided to download version 0.2.95 binary rpms (why is gnome-db still on ver. 0.2.94 and the other packages on version 0.2.95?). Installing them I got no dependacy problems. As I ran gnome-db the interface ran well. So I called the connection manager and selected the database that I wanted to connect to (after filling it in the manager section). Then I got an error message which told me "connectDBStart() -- connect() failed: Connection refused. Is the postmaster running (with -i) at ''and accepting connections on TCP/IP port 5432?". Error message -> 0

Whne I upgraded to postgresql I set the pg_hda.conf entry for so this is not the problem. I didn't do any network corrections since I upgraded so I don't think it's a postmaster refuseing the request unless the new installation of postgresql dosn't start the postmaster correctly. As a matter of fact I noticed that during boot the postmaster is not started. I have to start it manually by /etc/rc.d/init.d/postgresql start on my RH7.1. But anyway, when I start it pgsql connects to my databases correctly and gives me no problems.

If I call the connection dialog to connect to the database for a second time it crashes a the window gets locked. I have to kill it with xkill.

I wanted to try running through gdb but forgot how to get a dump of the execution (I'm not a programmer but I think this could have helped you guys understand what's going wrong ;-))

Hope someone helps me out. I was getting used to this nice software and pgsql was  getting rather small.

BTW. I wanted to try building the source rpms but got discouraged but the numerous dependacies:

[root gaia gnome-db-0.2.95]# rpm --rebuild libgda-0.2.95-1mdk.src.rpm 
Installing libgda-0.2.95-1mdk.src.rpm
error: failed build dependencies:
	MySQL-devel is needed by libgda-0.2.95-1mdk
	libxslt-devel is needed by libgda-0.2.95-1mdk
	popt-devel is needed by libgda-0.2.95-1mdk
	postgresql-devel is needed by libgda-0.2.95-1mdk

Why do I need MySQL when I don't want to use it?

[root gaia gnome-db-0.2.95]# rpm --rebuild gnome-db-0.2.95-1mdk.src.rpm 
Installing gnome-db-0.2.95-1mdk.src.rpm
error: failed build dependencies:
	freetype2-devel is needed by gnome-db-0.2.95-1mdk
	libbonobo2-devel is needed by gnome-db-0.2.95-1mdk
	libgda0-devel >= 0.2.93 is needed by gnome-db-0.2.95-1mdk
	mawk is needed by gnome-db-0.2.95-1mdk
	perl-devel is needed by gnome-db-0.2.95-1mdk
	xpm-devel is needed by gnome-db-0.2.95-1mdk

Hope someone can give me a better solution than installing all these dependancies. I only have 200MB left on my HD ........


                 Antonio Gennarini
                Crecchio, CH - ITALY
Earth Science student at University "G. D'Annunzio".
     Join th GNU generation, start from LINUX.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]