Re: Bonobo Activation Server goes to sleep

Thanks for your reply, Michael!

On Mon, 2003-12-15 at 20:51, Michael Meeks wrote: 
> 	What version of ORBit2 do you have; 


> also, it may be interesting to get
> a stack trace from gnome-session, find it's pid and do:
> 	gdb gnome-session <pid>
> 	backtrace

OK, perhaps I should explain a bit of background now. I am using
garnome-0.27.1. Consequently, it has installed gnome-2.4.0 into my
~/garnome directory without breaking my gnome-2.2.0 setup. I have filled
out my ~/.xsession file exactly as the documentation specifies. Yet for
some reason gnome-2.4.0 will not start up in runlevel 6, only 2.2.0. To
get 2.4.0, I have to run startx from runlevel 3. When GNOME hung, I used
ctrl+alt+F2 and logged in again to return to the command prompt. Then I
ran ps ax for the pid for the instance of gnome-session still running.
>From that pid, I ran your commands and received the following output. 

#0  0xffffe002 in ?? ()
#1  0x40256676 in ?? ()
#2  0x40256738 in ?? ()
#3  0x4005fd30 in ?? ()
#4  0x409b9612 in ?? ()
#5  0x409b860e in ?? ()
#6  0x409b8807 in ?? ()
#7  0x4042c94e in ?? ()
#8  0x4042cb0d in ?? ()
#9  0x0805742b in splash_widget_add_icon ()
#10 0x08052c75 in find_string_property ()
#11 0x42015574 in ?? ()

> 	If that fails, login as failsafe x term thing; do a bonobo-slay, then
> run: strace -f -ttt gnome-session >& /tmp/log.
> 	Then post a _link_ to the log :-)

I've done this too, and received the following output:

> 	Hopefully we can find what's going on from that,
> 	Regards,
> 		Michael.

I really appreciate this, Michael. I've spent weeks looking at different
debug outputs for gnome-session, EsounD and bonobo-activation-server.
It's taught me a lot about troubleshooting. But I finally decided I need
some kind of help!

Thanks a million,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]