Re: GNOME 2.26 Showstopper Review

On Mon, 2009-02-23 at 21:41 +0100, Gian Mario Tagliaretti wrote:
> On Mon, Feb 23, 2009 at 8:43 PM, Andre Klapper <ak-47 gmx net> wrote:
> Andre,
> > * :
> > gnome-games, gnome-python-desktop, gnome-devel-docs (update)
> >
> > * :
> > PATCHES: dasher
> > TODO: gnome-python-desktop, gnome-utils/gsearchtool
> I don't think that gnome-python-desktop would need removing GtkPrint
> and gnomeVFS, it contains GnomePrint python bindings which cannot be
> removed and I cannot find any reference to GnomeVFS that needs to be
> removed.
> If I'm mistaking please correct me, cc'ing Gustavo for a better opinion.

Some months later, in gnome-2.28.modules file in jhbuild those two
modules are still part of gnome 2.28.  Someone please let me know if
this changes.

And anyway I am not going to bother to physically move code from one
module to another for just a couple of library bindings, just not worth
the trouble.

I am, however, welcome to take other steps to deprecate the bindings:
  1. Add a python warning every time the deprecated module is imported;
  2. Not build the deprecatd bindings by default unless a
--enable-deprecated-bindings option is used.

Gustavo J. A. M. Carneiro
<gjc inescporto pt> <gustavo users sourceforge net>
"The universe is always one step beyond logic" -- Frank Herbert

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]