Re: I need an accessible mozilla

Dear Bernard,

Life is massively broken at present with the public mozilla and Gnopernicus. Changes in both led to some distance between them. Both the folks at BAUM and the folks in Sun working on mozilla accessibility are in close communication working to remedy the situation. The internal builds I'm playing with suggest we'll have the old functionality restored soon (after the GNOME 2.6.0 freeze is lifted, and after the various reviews and superreviews that are the custom in the Mozilla community).


Peter Korn
Sun Accessibility team

mailing list account wrote:
Dear list,
Once upon a time (maybe one year ago), I could use a fully accessible mozilla. By that I mean not only the widgets, but also the HTML rendering frame.
I could use at-poke to explore the page, including images, URLs etc.
I'm not sure anymore but I think it was with some debian unstable package of a cvs mozilla version. I did this by setting an env. variable GNOME_ACCESSIBILITY=1.
I'm not sure but I think I also had GTK_MODULES=mai:atk-bridge .

Today, many upgrade later, I *cannot* do that anymore with mozilla :-(

I tried on my debian unstable and on a Mandrake 9.2 box.
I recompile the mozilla packages (mozilla-1.6-9 on debian ) from source, setting --enable-accessibility in debian/rules (CONFIGURE_OPTIONS) as can be seen in about:about

--prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man --infodir=/usr/share/info --localstatedir=/var --disable-pedantic --with-default-mozilla-five-home=/usr/lib/mozilla --disable-debug --disable-tests --disable-short-wchar --enable-xprint --enable-strip-libs --enable-crypto --enable-mathml --enable-oji --enable-extensions=all --enable-ldap --with-system-zlib --enable-freetype2 --enable-default-toolkit=gtk2 --enable-toolkit=gtk2 --enable-accessibility --enable-svg --without-system-mng --without-system-png --disable-xft I am also using GNOME 2.6 from jhbuild cvs on my debian devel box, so I tried in a clean Mandrake 9.2 (mozilla 1.6 src.rpm), adding --enable-accessibility in mozilla.spec.

to no avail :-(

I have gconftool-2 --set "/desktop/gnome/interface/accessibility" --type boolean "True" and export GNOME_ACCESSIBILITY=1
in my ~/.bashrc

Under galeon, I *can* at-poke at rendered HTML pages ...

Any clue about what I am doing wrong would be *greatly* appreciated !

Thank you very much.

gnome-accessibility-list mailing list
gnome-accessibility-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]