Re: Compiling Gnopernicus under Debian unstable

Hi Jason,

On Sun, 2004-01-25 at 19:07, Jason White wrote:
> Now for the next problem:
> gnopernicus/ couldn't find either gnome-mag or gnome-speech,
> so I decided to compile gnome-speech and install it, in the hope of
> using the DECTALK driver.
> gnome-speech/ yields errors (output included below). I
> suspect this may be related to autoconf but I don't have a solution -
> I don't know much about autoconf or the design of Gnome. Here is the
> full output (better too much than too little in these
> circumstances):
> [gnome-speech jdc]$ ./ --prefix=/usr/local
> checking for autoconf >= 2.53...
>   testing autoconf2.50... not found.
>   testing autoconf... found 2.59
> checking for automake >= 1.5...
>   testing automake-1.7... found 1.7.9
> checking for libtool >= 1.5...
>   testing libtoolize... found 1.5.0a
> checking for pkg-config >= 0.14.0...
>   testing pkg-config... found 0.15.0
> Checking for required M4 macros...
> Checking for forbidden M4 macros...
> Processing ./
> Running aclocal-1.7...
> *** obsolete gnome macros were used in ./

Okay, all of these errors are caused by the same problem: for some
reason, your system is trying to build gnome-speech using an
automake-1.7, instead of automake-1.4. This is a problem because
automake versions 1.5 and later are not backwards compatible with

Over time (after GNOME 2.6) we will slowly help maintainers move all
their packages forwards to use something like automake-1.7, but for now
automake-1.4 and a recent automake version are both required to build
everything in GNOME.

[A few minutes later...]

When I read this, I just had a bad feeling about something Debian might
have done. Sure enough, the Debian packager of gnome-common has decided
to make automake-1.5 the minimal default version. This is COMPLETELY
BROKEN and shows a lack of understanding of the bigger picture on the
downstream packager's part. He even added a comment to the Debian log
saying "works with current GNOME CVS modules (closes: #221843)", which
is obviously wrong -- as your current build experiences indicate. Man, I
am only a little bit annoyed about this! The problem is that their
gnome-common package is now broken as far as building generic GNOME CVS
packages goes and that is the only reason that package exists.

So the solution from your point of view is: please do not use the
gnome-common package from Debian. It is broken. Get the GNOME version
from CVS (best to get the CVS version, since it has the latest bug
fixes) and install that.

(Sorry for the long email, but I was diagnosing things as I wrote this
and suddenly realised what the proper reason for the problem was. I have
to go away and file a Debian bug report now.)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]