Re: having trouble compiling Gnopernicus 0.7.3

Hi Scott,

On Sun, 2004-01-25 at 10:05, Scott Berry wrote:
> I am wondering if some one can help me figure out what this error message
> means when I try to configure Gnopernicus.  My guesses are as follows:  1.
> It could be telling me to upgrade some library packges.  or 2.  It may be
> telling me that it is just not finding these libraries on the path
> variable.  Thanks and appreciate the help.
> This is the error message:
> error: Library requirements (                  gconf-2.0 >= 1.1.5
>  glib-2.0 >= 1.3.12               libxml-2.0 >= 2.4.6) not met; consider
> adjusting the PKG_CONFIG_PATH environment variable if your libraries are
> in a nonstandard prefix so pkg-config can find them.

Just before that error message it will tell you the exact package that
is failing, so if you could post another half-dozen lines before that
message that would be most helpful.

Your diagnosis is basically correct: it cannot find the pkg-config
configuration file for one of these packages (or if it could find them
all, one of the packages is too old). Possible causes of this are that
either one version is too old, or you not have the appropriate
development files installed for one of these packages. On most
distributions, the runtime libraries come in one package, the
development files -- header files, *.pc files and so on -- come in
another package, usually with a -devel suffix on the package name.

So if the problem is not immediately clear from the couple of lines of
output preceding the line you posted, could you tell us what
distribution you are using and whether you are installing all of the
software yourself, or using packages that came with your distribution.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]