FreeTTS with Gnome-Speech Question

I'm tryhing to get Gnopernicus working again. The compiles appear to have gone without a hitch using the latest Red Hat
betas, named Phoebe. And, Gnopernicus launches just fine.

My problem is that I get Mickey Mouse from Festival, which is the only speech test-speech seems to be able to find.

I have tried both the Red Hat supplied Festival-1.4.2, and a compile of the February release of Festival-1.4.3. Same
story, speech appears to come at 4-times speed (or even greater).

I get the same undesirable effect from ViaVoice 5.1, which I have only as binaries, of course.

Strangely, Festival Lite, which I compiled afresh, as there's now a 1.2 release, works fine.

I have also obtained the j2sdk-1.4.1_02 from, and have compiled FreeTTS from cvs today. FreeTTS talks
appropriately when I launch either the freetts (client) or frettsServer scripts. However, test-speech doesn't seem to
see FreeTTS.

Am I starting them correctly? I cd to the directory containing these scripts and issue ./[] as root. Should I
do this differently?

NOTE: If, instead, i run the jar script, I get:

Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/speech/freetts/FreeTTS

Can I use FreeTTS with gnome-speech? How should I start and test?

Thanks for any help.

				Janina Sajka, Director
				Technology Research and Development
				Governmental Relations Group
				American Foundation for the Blind (AFB)

Email: janina afb net		Phone: (202) 408-8175

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]