[Glade-users] New Installation from Librecore

First I was using the version that was distributed last year (I believe that 
was 3.8.3).
And I always believe in using the latest version of a distribution.

In the mean time I found the folowing when starting my program with the run 

Gtk-WARNING **: Unknown type < define a new column > spevified in treemodel 

Gtk-WARNING **: ../../src/gtk/gtkliststore.c:516: Invalid type (null)

Gtk-Message: GtkDialog mapped without a transient parent. This is 

I do start the program with the lines:

Gtk_New (Builder);
Error_nr := Add_From_File (Builder, "Program.glade", Error'Access);
if Error /= null then
   -- Create an Error Message Window in case the an error resulted from 
   answer := Message_Dialog( Msg     => "No correct file wth the name 
                             Buttons => Button_OK,
                             Title   => "Error");
   Error_Free (Error);
end if;

As I did with the last version also.
This means that the Error messages in the GPS occur before the Message Box 

At the top of the file I do have:

<?xml version="1.0" encoding="UTF-8"?>
<!-- Generated with glade 3.16.1 -->

-----Oorspronkelijk bericht----- 
From: Tristan Van Berkom
Sent: Sunday, June 5, 2016 10:00 AM
To: bertus.dries at planet.nl
Cc: glade-users
Subject: Re: [Glade-users] New Installation from Librecore


It's hard to say whats going wrong, what version of Glade were you
previously using ? If you were using Glade 3.8.x - then you need to
continue using Glade 3.8.x (which is parallel installable with Glade
= 3.10) which generates XML for the older libglade format as well as
GtkBuilder format for GTK+2.x.

From your message, I suspect that you are looking at an older code
base which still uses libglade and GTK+2, but as I said it's hard to
say whats going on without further information.

What were the warnings that you saw when running your program ?

In your glade file, does it say <glade-interface> at the top level ?
or <interface> ?

What api are you using to load the glade file through your Ada
bindings, bindings to libglade or to GTK+'s GtkBuilder ?


On Sun, Jun 5, 2016 at 4:09 PM,  <bertus.dries at planet.nl> wrote:
I just made a new installation from Librecore of GPS and GtkAda. In the
GtkAda installation a new version of glade was introduced (3.16.1). When I
tried to run in GPS a programwhich uses a .glade file I got several
warnings. Then I tried via properties to change the toolkit version to 
and my program (in the meantime rebuild ). My program did not recognized 
.glade file as a correct file.

Which is the correct combination I should use with the new installation. I
am running on Windows 10.

L. Dries
Glade-users maillist  -  Glade-users at lists.ximian.com

Geen virus gevonden in dit bericht.
Gecontroleerd door AVG - www.avg.com
Versie: 2016.0.7639 / Virusdatabase: 4591/12360 - datum van uitgifte: 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]