[Glade-users] New Installation from Librecore


It's hard to say whats going wrong, what version of Glade were you
previously using ? If you were using Glade 3.8.x - then you need to
continue using Glade 3.8.x (which is parallel installable with Glade
= 3.10) which generates XML for the older libglade format as well as
GtkBuilder format for GTK+2.x.

From your message, I suspect that you are looking at an older code
base which still uses libglade and GTK+2, but as I said it's hard to
say whats going on without further information.

What were the warnings that you saw when running your program ?

In your glade file, does it say <glade-interface> at the top level ?
or <interface> ?

What api are you using to load the glade file through your Ada
bindings, bindings to libglade or to GTK+'s GtkBuilder ?


On Sun, Jun 5, 2016 at 4:09 PM,  <bertus.dries at planet.nl> wrote:
I just made a new installation from Librecore of GPS and GtkAda. In the
GtkAda installation a new version of glade was introduced (3.16.1). When I
tried to run in GPS a programwhich uses a .glade file I got several
warnings. Then I tried via properties to change the toolkit version to 3.10
and my program (in the meantime rebuild ). My program did not recognized the
.glade file as a correct file.

Which is the correct combination I should use with the new installation. I
am running on Windows 10.

L. Dries
Glade-users maillist  -  Glade-users at lists.ximian.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]