[Glade-users] Glade / Gtk+ version mismatch and fatal errors

Hi all.

I just created a builder file with Glade-3.18.3. I left the target version
as the default ( 3.18 ) and deployed to a system with gtk-3.14.3. I got an
error ( which prevented the window from opening at all ):

*** unhandled exception in callback:
***   Invalid property: GtkPaned.wide_handle on line 24 at
c:/strawberry/perl/site/lib/Gtk3.pm line 544.
***   ignoring at c:/starberry/perl/site/lib/Gtk3.pm line 318.

So I went back into glade, loaded this builder file, went to File ==>
Properties and looked at the 'Toolkit version required' area.

The *latest* was 3.12 - which is *earlier* than my gtk version on the
system I'm deploying to. Anyway I set it back to 3.8, clicked the 'verify'
button ( there were no version mismatches ), saved, deployed, and tried
again. Unfortunately, I get the same error.

I worked around the issue by unsetting the 'wide handle' toggle on the
paned widget.

It might be better for whatever's throwing this error to make it

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/glade-users/attachments/20151002/2400c66f/attachment.html>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]