[Glade-users] GtkEntry

Yes, that's correct there should not be a comma, my typo, playing too 
long with it.  Unfortunately I still get the same error.

On 06/09/2014 08:47 PM, narcisse doudieu siewe wrote:
replace with
txt_pt = gtk_entry_get_text (GtkEntry(entry));

the is problem, the comma after GtkEntry

Le Mardi 10 juin 2014 1h14, Ian Chapman <ichapman at videotron.ca> a ?crit :

Many thanks to John and Martin for their help. I've another difficulty
that I do could not figure out. In glade 3.14.2 I have window with a
container box and in one of the compartments of the box I have Text
Entry that shows in the inspector as GtkEntry (FileName).
I should be able to read the text with
const gchar *txt_pt;
txt_pt = gtk_entry_get_text (GtkEntry, (entry)); // error: expected
expression before ?GtkEntry?

I should also be able to write with
gtk_entry_set_text (GtkEntry entry, "hello"); //expected declaration
specifiers or ?...? before string constant

But I get these errors. Also if I have more than one Text Entry how do I
select between them? Thanks in advance Ian.

Glade-users maillist  - Glade-users at lists.ximian.com 
<mailto:Glade-users at lists.ximian.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/glade-users/attachments/20140609/b96a9c52/attachment.html>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]