[Glade-users] glade-2 gtkada code generation doesn't work with signals

On Wed, 2005-02-02 at 10:08, Gabriel Rossetti wrote:

I used glade-2 to create a window, I put a FixedPosition object in the 
window and a button in that. Then
I added a clicked signal and saved the file. After that I did a build 
and I get this error :

Error running gate to generate the Ada95 source code.
Check that you have gate installed and that it is in your PATH.
Then try running 'gate <project_file.glade>' in a terminal.

I checked and gate is indeed in my path, so I tried to run it manually 
and I get this :

$ gate project4.glade
Generating Ada files...

(gate-in.exe:15711): GLib-GObject-CRITICAL **: g_signal_lookup: 
(itype)' failed
Couldn't generate Ada code. Exiting.

My lab partner also has the same problem, but he has an older version.

The Ada code generator is maintained separately, so I can't help I 'm
afraid. You could ask for help on the GtkAda mailing list:
Though it looks like you already have!

Also, glade doesn't want to store images in the pixmaps directory as 
asked, it just puts them in src. I tried crea
ting the pixmaps directory andmoving them, but it just recreated the 
images in src.

Check the "Pixmaps Directory" settting in the project options.
Noone else has reported problems with this, so I don't think it is a
Glade problem.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]