[Glade-users] trouble with multithreads in GTK+ and GNOME application

Hi everybody,

I am new to GLADE and writing an application in which
I need 'timer'. I tried to use multiple threads and it
worked to some extent, actually timer started as I
wanted (with a button-click) and kept running for some
30 sec and after that application's display stoped
refreshing. I mean as I minimized and again restored
it didn't show all the widgets but just a blank-white
window, second time when I restarted the application,
it worked well for sometime, and after some 10-15
seconds, when I started hovering my mouse over buttons
I had in the application they stoped
depressing(normaly they depress and color becomes a
little bright, as mouse pointer comes over them).
After this timer also stopped refreshing the display.
Anyway, exit button in my application works(though it
dosen't respond to mouse hovering).
I used POSIX thread library for this. Earlier I had
used POSIX threads for the same type of application
programed with ncurses routines and it worked well(no
In GTK+ or GNOME is there anyway to solve this
problem?? I wnated to implement gthreads but couldn't
figure out what was all that locking stuff.
Is there anyway to do this without threads or anyway
threads can be made to work correctly. (Plz give
example code of thread implementation in GTK+ and
GNOME applications if possible)

Plz help....
Thanks in advance....

Janmejay Singh
IIT Roorkee

Do you Yahoo!?
New and Improved Yahoo! Mail - 100MB free storage!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]